aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2011-05-22 14:29:51 +0000
committermarha <marha@users.sourceforge.net>2011-05-22 14:29:51 +0000
commit016747a04df9d4474489fe3b3d1c0f11a713148b (patch)
tree69722f37ac06c00d6674c7bf2df6597753b418e6 /mesalib/configure.ac
parent32a666fa1f26defd3b4e508b75f1acf6e2900a40 (diff)
parent52011cfedaa930d61d8f60b283a2051093727582 (diff)
downloadvcxsrv-016747a04df9d4474489fe3b3d1c0f11a713148b.tar.gz
vcxsrv-016747a04df9d4474489fe3b3d1c0f11a713148b.tar.bz2
vcxsrv-016747a04df9d4474489fe3b3d1c0f11a713148b.zip
svn merge ^/branches/released .
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index 2101337a2..a201c31ae 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -39,6 +39,12 @@ if test "x$MKDEP" = "x"; then
AC_MSG_ERROR([makedepend is required to build Mesa])
fi
+AC_PATH_PROG([FLEX], [flex])
+test "x$FLEX" = "x" && AC_MSG_ERROR([flex is needed to build Mesa])
+
+AC_PATH_PROG([BISON], [bison])
+test "x$BISON" = "x" && AC_MSG_ERROR([bison is needed to build Mesa])
+
dnl Our fallback install-sh is a symlink to minstall. Use the existing
dnl configuration in that case.
AC_PROG_INSTALL
@@ -1186,7 +1192,7 @@ if test "x$enable_egl" = xno; then
fi
if test "x$enable_egl" = xyes; then
SRC_DIRS="$SRC_DIRS egl"
- EGL_LIB_DEPS="$DLOPEN_LIBS -lpthread"
+ EGL_LIB_DEPS="$DLOPEN_LIBS $SELINUX_LIBS -lpthread"
EGL_DRIVERS_DIRS=""
if test "$enable_static" != yes; then
# build egl_glx when libGL is built
@@ -1581,7 +1587,7 @@ x*yes*)
esac
if test "x$enable_openvg" = xyes; then
EGL_CLIENT_APIS="$EGL_CLIENT_APIS "'$(VG_LIB)'
- VG_LIB_DEPS="$VG_LIB_DEPS -lpthread"
+ VG_LIB_DEPS="$VG_LIB_DEPS $SELINUX_LIBS -lpthread"
fi
AC_SUBST([VG_LIB_DEPS])