aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2013-01-31 08:14:38 +0100
committermarha <marha@users.sourceforge.net>2013-01-31 08:14:38 +0100
commit3dc034dda1a451ed7dc48cfb10caba11e66b4132 (patch)
treeac2f7522e5b3287afdb5dcd5af6d9c6bb9a3d079 /mesalib/configure.ac
parent4e7e0bd9194a033f05179fb64126c56fc6f072b5 (diff)
parent436f8246cd5a377596f6e42e6562da186ef8df48 (diff)
downloadvcxsrv-3dc034dda1a451ed7dc48cfb10caba11e66b4132.tar.gz
vcxsrv-3dc034dda1a451ed7dc48cfb10caba11e66b4132.tar.bz2
vcxsrv-3dc034dda1a451ed7dc48cfb10caba11e66b4132.zip
Merge remote-tracking branch 'origin/released'
* origin/released: libxtrans mesa pixman xkeyboard-config git update 31 jan 2013
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index 9cc5c4ae5..564ca3ccf 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -57,10 +57,10 @@ LT_PREREQ([2.2])
LT_INIT([disable-static])
AX_PROG_BISON([],
- AS_IF([test ! -f "$srcdir/src/glsl/glcpp/glcpp-parse.c"]
+ AS_IF([test ! -f "$srcdir/src/glsl/glcpp/glcpp-parse.c"],
[AC_MSG_ERROR([bison not found - unable to compile glcpp-parse.y])]))
AX_PROG_FLEX([],
- AS_IF([test ! -f "$srcdir/src/glsl/glcpp/glcpp-lex.c"]
+ AS_IF([test ! -f "$srcdir/src/glsl/glcpp/glcpp-lex.c"],
[AC_MSG_ERROR([flex not found - unable to compile glcpp-lex.l])]))
AC_PATH_PROG([PERL], [perl])
@@ -1834,14 +1834,12 @@ if test "x$with_gallium_drivers" != x; then
if test "x$enable_r600_llvm" = xyes -o "x$enable_opencl" = xyes; then
radeon_llvm_check
NEED_RADEON_GALLIUM=yes;
- LLVM_COMPONENTS="${LLVM_COMPONENTS} ipo"
+ R600_NEED_RADEON_GALLIUM=yes;
+ LLVM_COMPONENTS="${LLVM_COMPONENTS} ipo bitreader asmparser"
fi
if test "x$enable_r600_llvm" = xyes; then
USE_R600_LLVM_COMPILER=yes;
fi
- if test "x$enable_opencl" = xyes -a "x$with_llvm_shared_libs" = xno; then
- LLVM_COMPONENTS="${LLVM_COMPONENTS} bitreader asmparser"
- fi
gallium_check_st "radeon/drm" "dri-r600" "xorg-r600" "" "xvmc-r600" "vdpau-r600"
;;
xradeonsi)
@@ -1990,6 +1988,7 @@ AM_CONDITIONAL(HAVE_GALAHAD_GALLIUM, test x$HAVE_GALAHAD_GALLIUM = xyes)
AM_CONDITIONAL(HAVE_IDENTITY_GALLIUM, test x$HAVE_IDENTITY_GALLIUM = xyes)
AM_CONDITIONAL(HAVE_NOOP_GALLIUM, test x$HAVE_NOOP_GALLIUM = xyes)
AM_CONDITIONAL(NEED_RADEON_GALLIUM, test x$NEED_RADEON_GALLIUM = xyes)
+AM_CONDITIONAL(R600_NEED_RADEON_GALLIUM, test x$R600_NEED_RADEON_GALLIUM = xyes)
AM_CONDITIONAL(USE_R600_LLVM_COMPILER, test x$USE_R600_LLVM_COMPILER = xyes)
AM_CONDITIONAL(HAVE_LOADER_GALLIUM, test x$enable_gallium_loader = xyes)
AM_CONDITIONAL(HAVE_DRM_LOADER_GALLIUM, test x$enable_gallium_drm_loader = xyes)