aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2014-03-09 22:56:02 +0100
committermarha <marha@users.sourceforge.net>2014-03-09 22:56:02 +0100
commit2112b7dec49833ba872bd3ebcd7288930fec0796 (patch)
tree407c80c9a70f590af2d4c3e5c14678827e189331 /mesalib/configure.ac
parent8badbdef38ce843dc443ddee219eda4040ef2cd5 (diff)
parent3dd4b6420f686b0147d5b8136268cc63196e253b (diff)
downloadvcxsrv-2112b7dec49833ba872bd3ebcd7288930fec0796.tar.gz
vcxsrv-2112b7dec49833ba872bd3ebcd7288930fec0796.tar.bz2
vcxsrv-2112b7dec49833ba872bd3ebcd7288930fec0796.zip
Merge remote-tracking branch 'origin/released'
* origin/released: fontconfig mesa xserver git update 9 Mar 2014 Conflicts: mesalib/src/mapi/glapi/glapi.h xorg-server/hw/kdrive/ephyr/hostx.c
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index d54cba36d..3f752664b 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -611,7 +611,7 @@ AC_ARG_ENABLE([omx],
AC_ARG_ENABLE([opencl],
[AS_HELP_STRING([--enable-opencl],
[enable OpenCL library NOTE: Enabling this option will also enable
- --with-llvm-shared-libs
+ --enable-llvm-shared-libs
@<:@default=no@:>@])],
[],
[enable_opencl=no])
@@ -994,6 +994,10 @@ if test "x$enable_dri" = xyes; then
DEFINES="$DEFINES -DHAVE_DRI3"
fi
+ if test "x$have_libudev" != xyes; then
+ AC_MSG_ERROR([libudev-dev required for building DRI])
+ fi
+
case "$host_cpu" in
powerpc* | sparc*)
# Build only the drivers for cards that exist on PowerPC/sparc
@@ -1068,7 +1072,7 @@ if test -n "$with_dri_drivers"; then
dri_drivers=`IFS=', '; echo $with_dri_drivers`
for driver in $dri_drivers; do
- DRI_DIRS+="$driver "
+ DRI_DIRS="$DRI_DIRS $driver"
case "x$driver" in
xi915)
HAVE_I915_DRI=yes;
@@ -1888,7 +1892,7 @@ if test "x$MESA_LLVM" != x0; then
can use the --with-llvm-prefix= configure flag to specify this directory.
NOTE: Mesa is attempting to use llvm shared libraries because you have
passed one of the following options to configure:
- --with-llvm-shared-libs
+ --enable-llvm-shared-libs
--enable-opencl
If you do not want to build with llvm shared libraries and instead want to
use llvm static libraries then remove these options from your configure