aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2013-02-05 08:22:00 +0100
committermarha <marha@users.sourceforge.net>2013-02-05 08:23:51 +0100
commit76c527be60066b647468ad66f8e4d7dd18fa1769 (patch)
tree2e4653dc3adf874409cf9baba399fd64537115d4 /mesalib/configure.ac
parenta6d5f8de1394c338d01b65be7dba3520bf8bdf4b (diff)
downloadvcxsrv-76c527be60066b647468ad66f8e4d7dd18fa1769.tar.gz
vcxsrv-76c527be60066b647468ad66f8e4d7dd18fa1769.tar.bz2
vcxsrv-76c527be60066b647468ad66f8e4d7dd18fa1769.zip
fontconfig mesa xkeyboard-config git update 5 feb 2013
xkeyboard-config commit b4be67b48fb11989f1824dd0b1c8c399430162b0 fontconfig commit 95af7447dba7c54ed162b667c0bb2ea6500e8f32 mesa commit 86536a321d9d26137587affe687a07da71f0b526
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac19
1 files changed, 17 insertions, 2 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index cfd52bfcf..abfe3d7bd 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -611,7 +611,7 @@ AC_ARG_ENABLE([opencl],
[enable OpenCL library NOTE: Enabling this option will also enable
--with-llvm-shared-libs
@<:@default=no@:>@])],
- [enable_opencl="$enableval" with_llvm_shared_libs="$enableval"],
+ [],
[enable_opencl=no])
AC_ARG_ENABLE([xlib_glx],
[AS_HELP_STRING([--enable-xlib-glx],
@@ -701,6 +701,16 @@ if test "x$enable_dri$enable_xlib_glx" = xyesyes; then
AC_MSG_ERROR([DRI and Xlib-GLX cannot be built together])
fi
+if test "x$enable_opengl$enable_xlib_glx" = xnoyes; then
+ AC_MSG_ERROR([Xlib-GLX cannot be built without OpenGL])
+fi
+
+# Disable GLX if OpenGL is not enabled
+if test "x$enable_glx$enable_opengl" = xyesno; then
+ AC_MSG_WARN([OpenGL not enabled, disabling GLX])
+ enable_glx=no
+fi
+
# Disable GLX if DRI and Xlib-GLX are not enabled
if test "x$enable_glx" = xyes -a \
"x$enable_dri" = xno -a \
@@ -1619,8 +1629,13 @@ AC_ARG_ENABLE([gallium-llvm],
AC_ARG_WITH([llvm-shared-libs],
[AS_HELP_STRING([--with-llvm-shared-libs],
[link with LLVM shared libraries @<:@default=disabled@:>@])],
- [with_llvm_shared_libs=yes],
+ [],
[with_llvm_shared_libs=no])
+AS_IF([test x$enable_opencl = xyes],
+ [
+ AC_MSG_WARN([OpenCL required, forcing LLVM shared libraries])
+ with_llvm_shared_libs=yes
+ ])
AC_ARG_WITH([llvm-prefix],
[AS_HELP_STRING([--with-llvm-prefix],