aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2011-07-26 12:48:28 +0200
committermarha <marha@users.sourceforge.net>2011-07-26 12:48:28 +0200
commitdc23661fa1d58aa98d67fae47a919de452b8cd28 (patch)
tree0a8c7987f3756290e3ba9cfb8cdf23d6e9532037 /mesalib/configure.ac
parent8680f93ff96770b0a022596d8d4092a29c586435 (diff)
parentece07bdeaa82ea59e74bcfc588bcabe5e47567c1 (diff)
downloadvcxsrv-dc23661fa1d58aa98d67fae47a919de452b8cd28.tar.gz
vcxsrv-dc23661fa1d58aa98d67fae47a919de452b8cd28.tar.bz2
vcxsrv-dc23661fa1d58aa98d67fae47a919de452b8cd28.zip
Merge remote-tracking branch 'origin/released'
Conflicts: libX11/specs/libX11/CH11.xml mesalib/src/glsl/main.cpp mesalib/src/mesa/main/compiler.h mesalib/src/mesa/main/get.c mesalib/src/mesa/main/texcompress.c mesalib/src/mesa/main/texparam.c mesalib/src/mesa/program/ir_to_mesa.cpp mesalib/src/mesa/program/prog_optimize.c pixman/pixman/pixman-fast-path.c pixman/pixman/pixman-fast-path.h xorg-server/hw/xquartz/GL/indirect.c xorg-server/hw/xquartz/X11Application.h xorg-server/hw/xquartz/X11Application.m xorg-server/hw/xquartz/bundle/Resources/French.lproj/locversion.plist xorg-server/hw/xquartz/bundle/Resources/French.lproj/main.nib/designable.nib xorg-server/hw/xquartz/bundle/Resources/German.lproj/locversion.plist xorg-server/hw/xquartz/bundle/Resources/German.lproj/main.nib/designable.nib xorg-server/hw/xquartz/bundle/Resources/Japanese.lproj/locversion.plist xorg-server/hw/xquartz/bundle/Resources/Japanese.lproj/main.nib/designable.nib xorg-server/hw/xquartz/darwinEvents.c xorg-server/hw/xquartz/darwinEvents.h xorg-server/hw/xquartz/man/Xquartz.man xorg-server/hw/xquartz/xpr/dri.c xorg-server/xkeyboard-config/symbols/ee
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac75
1 files changed, 37 insertions, 38 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index 86ba87b39..5c832e646 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -1326,6 +1326,41 @@ AC_SUBST([OSMESA_PC_REQ])
AC_SUBST([OSMESA_PC_LIB_PRIV])
dnl
+dnl gbm configuration
+dnl
+if test "x$enable_gbm" = xauto; then
+ case "$with_egl_platforms" in
+ *drm*)
+ enable_gbm=yes ;;
+ *)
+ enable_gbm=no ;;
+ esac
+fi
+if test "x$enable_gbm" = xyes; then
+ SRC_DIRS="$SRC_DIRS gbm"
+ GBM_BACKEND_DIRS=""
+
+ PKG_CHECK_MODULES([LIBUDEV], [libudev], [],
+ AC_MSG_ERROR([gbm needs udev]))
+ GBM_LIB_DEPS="$DLOPEN_LIBS $LIBUDEV_LIBS"
+
+ if test "x$enable_dri" = xyes; then
+ GBM_BACKEND_DIRS="$GBM_BACKEND_DIRS dri"
+ if test "$SHARED_GLAPI" -eq 0; then
+ AC_MSG_ERROR([gbm_dri requires --enable-shared-glapi])
+ fi
+ fi
+fi
+AC_SUBST([GBM_LIB_DEPS])
+AC_SUBST([GBM_BACKEND_DIRS])
+GBM_PC_REQ_PRIV="libudev"
+GBM_PC_LIB_PRIV="$DLOPEN_LIBS"
+GBM_PC_CFLAGS=
+AC_SUBST([GBM_PC_REQ_PRIV])
+AC_SUBST([GBM_PC_LIB_PRIV])
+AC_SUBST([GBM_PC_CFLAGS])
+
+dnl
dnl EGL configuration
dnl
EGL_CLIENT_APIS=""
@@ -1367,41 +1402,6 @@ AC_SUBST([EGL_LIB_DEPS])
AC_SUBST([EGL_DRIVERS_DIRS])
dnl
-dnl gbm configuration
-dnl
-if test "x$enable_gbm" = xauto; then
- case "$with_egl_platforms" in
- *drm*)
- enable_gbm=yes ;;
- *)
- enable_gbm=no ;;
- esac
-fi
-if test "x$enable_gbm" = xyes; then
- SRC_DIRS="$SRC_DIRS gbm"
- GBM_BACKEND_DIRS=""
-
- PKG_CHECK_MODULES([LIBUDEV], [libudev], [],
- AC_MSG_ERROR([gbm needs udev]))
- GBM_LIB_DEPS="$DLOPEN_LIBS $LIBUDEV_LIBS"
-
- if test "x$enable_dri" = xyes; then
- GBM_BACKEND_DIRS="$GBM_BACKEND_DIRS dri"
- if test "$SHARED_GLAPI" -eq 0; then
- AC_MSG_ERROR([gbm_dri requires --enable-shared-glapi])
- fi
- fi
-fi
-AC_SUBST([GBM_LIB_DEPS])
-AC_SUBST([GBM_BACKEND_DIRS])
-GBM_PC_REQ_PRIV="libudev"
-GBM_PC_LIB_PRIV="$DLOPEN_LIBS"
-GBM_PC_CFLAGS=
-AC_SUBST([GBM_PC_REQ_PRIV])
-AC_SUBST([GBM_PC_LIB_PRIV])
-AC_SUBST([GBM_PC_CFLAGS])
-
-dnl
dnl EGL Gallium configuration
dnl
if test "x$enable_gallium_egl" = xyes; then
@@ -1699,9 +1699,6 @@ dnl Gallium configuration
dnl
if test "x$with_gallium_drivers" != x; then
SRC_DIRS="$SRC_DIRS gallium gallium/winsys gallium/targets"
- AC_PATH_PROG([LLVM_CONFIG], [llvm-config], [no])
-else
- LLVM_CONFIG=no
fi
AC_SUBST([LLVM_CFLAGS])
@@ -1821,6 +1818,8 @@ if test "x$enable_gallium_llvm" = xauto; then
esac
fi
if test "x$enable_gallium_llvm" = xyes; then
+ AC_PATH_PROG([LLVM_CONFIG], [llvm-config], [no])
+
if test "x$LLVM_CONFIG" != xno; then
LLVM_VERSION=`$LLVM_CONFIG --version`
LLVM_CFLAGS=`$LLVM_CONFIG --cppflags|sed 's/-DNDEBUG\>//g'`