aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2011-07-29 11:17:40 +0200
committermarha <marha@users.sourceforge.net>2011-07-29 11:17:40 +0200
commita69cff9373daf6b7afc97fb975ceb4fc0d6864f7 (patch)
tree2c04fb8e0dc217b9f418c8ec37f17973a93779a2 /mesalib/configure.ac
parentfa08275a130f5693e2add977df7cf38d44f2f8da (diff)
parent28257038c4f13ac26127d536c14c922aa036efed (diff)
downloadvcxsrv-a69cff9373daf6b7afc97fb975ceb4fc0d6864f7.tar.gz
vcxsrv-a69cff9373daf6b7afc97fb975ceb4fc0d6864f7.tar.bz2
vcxsrv-a69cff9373daf6b7afc97fb975ceb4fc0d6864f7.zip
Merge remote-tracking branch 'origin/released'
Conflicts: libX11/configure.ac mesalib/src/mesa/main/ff_fragment_shader.cpp mesalib/src/mesa/main/framebuffer.c mesalib/src/mesa/main/texparam.c pixman/pixman/pixman-arm-neon-asm.S
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac14
1 files changed, 6 insertions, 8 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index 5c832e646..1b1823a21 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -951,7 +951,7 @@ xyesyes)
GL_PC_LIB_PRIV="$GL_LIB_DEPS"
GL_PC_CFLAGS="$X11_INCLUDES"
fi
- GL_LIB_DEPS="$GL_LIB_DEPS $SELINUX_LIBS -lm -lpthread"
+ GL_LIB_DEPS="$GL_LIB_DEPS $SELINUX_LIBS -lm -lpthread $DLOPEN_LIBS"
GL_PC_LIB_PRIV="$GL_PC_LIB_PRIV $SELINUX_LIBS -lm -lpthread"
# if static, move the external libraries to the programs
@@ -1936,11 +1936,12 @@ if test "x$with_gallium_drivers" != x; then
gallium_check_st "nouveau/drm" "dri-nouveau" "xorg-nouveau" "" "xvmc-nouveau"
;;
xswrast)
+ GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS softpipe"
+ if test "x$MESA_LLVM" = x1; then
+ GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS llvmpipe"
+ fi
+
if test "x$HAVE_ST_DRI" = xyes; then
- GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS softpipe"
- if test "x$MESA_LLVM" = x1; then
- GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS llvmpipe"
- fi
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS dri-swrast"
fi
if test "x$HAVE_ST_VDPAU" = xyes; then
@@ -1958,9 +1959,6 @@ if test "x$with_gallium_drivers" != x; then
if test "x$HAVE_WINSYS_XLIB" != xyes; then
GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/xlib"
fi
- if test "x$HAVE_ST_DRI" != xyes; then
- GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS softpipe"
- fi
fi
;;
*)