aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2011-07-12 08:04:42 +0200
committermarha <marha@users.sourceforge.net>2011-07-12 08:04:42 +0200
commit3b47b2c35227184c0eb6dcf6dee8b79c4f9d4474 (patch)
treeba0e8f45ac50ead3283424f8794c7cbd38380805 /mesalib/configure.ac
parent0b43e0b4ddbd9fdac70658164f3dbf653067a4de (diff)
downloadvcxsrv-3b47b2c35227184c0eb6dcf6dee8b79c4f9d4474.tar.gz
vcxsrv-3b47b2c35227184c0eb6dcf6dee8b79c4f9d4474.tar.bz2
vcxsrv-3b47b2c35227184c0eb6dcf6dee8b79c4f9d4474.zip
mesa git update 12 July 2011
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index dde13c9b5..eace790d8 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -617,6 +617,13 @@ AC_ARG_WITH([gallium-drivers],
[with_gallium_drivers="$withval"],
[with_gallium_drivers="$GALLIUM_DRIVERS_DEFAULT"])
+# Doing '--without-gallium-drivers' will set this variable to 'no'. Clear it
+# here so that the script doesn't choke on an unknown driver name later.
+case "$with_gallium_drivers" in
+ yes) with_gallium_drivers="$GALLIUM_DRIVERS_DEFAULT" ;;
+ no) with_gallium_drivers='' ;;
+esac
+
if test "x$enable_opengl" = xno -a \
"x$enable_gles1" = xno -a \
"x$enable_gles2" = xno -a \
@@ -791,7 +798,7 @@ esac
if test "x$enable_dri" = xyes; then
DRIVER_DIRS="$DRIVER_DIRS dri"
- GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/xlib sw/dri"
+ GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/dri"
GALLIUM_STATE_TRACKERS_DIRS="dri $GALLIUM_STATE_TRACKERS_DIRS"
HAVE_ST_DRI="yes"
fi
@@ -1806,7 +1813,7 @@ fi
if test "x$enable_gallium_llvm" = xyes; then
if test "x$LLVM_CONFIG" != xno; then
LLVM_VERSION=`$LLVM_CONFIG --version`
- LLVM_CFLAGS=`$LLVM_CONFIG --cppflags`
+ LLVM_CFLAGS=`$LLVM_CONFIG --cppflags|sed 's/-DNDEBUG\>//g'`
LLVM_LIBS="`$LLVM_CONFIG --libs` -lstdc++"
LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`