aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2014-05-01 17:03:50 +0200
committermarha <marha@users.sourceforge.net>2014-05-01 17:03:50 +0200
commitaadab8d97e31348ffe45d1e5d36ad90b0ccd17aa (patch)
tree37bc7921f864ead4f6eb357b31a1eb66d46aaef9 /mesalib/configure.ac
parent2e0adb33e03e3142f1412ed570415c5ce616dcef (diff)
parentea0cd87ecbe9fc3c5503ccad7f87a895a458d6d4 (diff)
downloadvcxsrv-aadab8d97e31348ffe45d1e5d36ad90b0ccd17aa.tar.gz
vcxsrv-aadab8d97e31348ffe45d1e5d36ad90b0ccd17aa.tar.bz2
vcxsrv-aadab8d97e31348ffe45d1e5d36ad90b0ccd17aa.zip
Merge remote-tracking branch 'origin/released'
Conflicts: libxcb/src/xcb_util.c mesalib/src/mesa/drivers/dri/common/dri_util.c xorg-server/os/utils.c
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac15
1 files changed, 11 insertions, 4 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index c71fa2627..bf543c2d0 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -480,6 +480,12 @@ AC_CHECK_FUNC([dlopen], [DEFINES="$DEFINES -DHAVE_DLOPEN"],
[DEFINES="$DEFINES -DHAVE_DLOPEN"; DLOPEN_LIBS="-ldl"])])
AC_SUBST([DLOPEN_LIBS])
+dnl Check if that library also has dladdr
+save_LDFLAGS="$LDFLAGS"
+LDFLAGS="$LDFLAGS $DLOPEN_LIBS"
+AC_CHECK_FUNCS([dladdr])
+LDFLAGS="$save_LDFLAGS"
+
case "$host_os" in
darwin*|mingw*)
;;
@@ -1935,12 +1941,14 @@ AM_CONDITIONAL(NEED_GALLIUM_LLVMPIPE_DRIVER, test "x$HAVE_GALLIUM_I915" = xyes -
if test "x$enable_gallium_loader" = xyes; then
GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/null"
- if test "x$enable_gallium_xlib_loader" = xyes; then
- GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/xlib"
- NEED_WINSYS_XLIB="yes"
+ if test "x$NEED_WINSYS_XLIB" = xyes; then
GALLIUM_PIPE_LOADER_DEFINES="$GALLIUM_PIPE_LOADER_DEFINES -DHAVE_PIPE_LOADER_XLIB"
fi
+ if test "x$enable_dri" = xyes; then
+ GALLIUM_PIPE_LOADER_DEFINES="$GALLIUM_PIPE_LOADER_DEFINES -DHAVE_PIPE_LOADER_DRI"
+ fi
+
if test "x$enable_gallium_drm_loader" = xyes; then
GALLIUM_PIPE_LOADER_DEFINES="$GALLIUM_PIPE_LOADER_DEFINES -DHAVE_PIPE_LOADER_DRM"
PKG_CHECK_MODULES([GALLIUM_PIPE_LOADER_XCB], [xcb xcb-dri2],
@@ -1959,7 +1967,6 @@ if test "x$enable_gallium_loader" = xyes; then
AC_SUBST([GALLIUM_PIPE_LOADER_CLIENT_DEFINES])
AC_SUBST([GALLIUM_PIPE_LOADER_CLIENT_LIBS])
fi
-AM_CONDITIONAL(NEED_PIPE_LOADER_XLIB, test "x$enable_gallium_xlib_loader" = xyes)
AM_CONDITIONAL(HAVE_I915_DRI, test x$HAVE_I915_DRI = xyes)
AM_CONDITIONAL(HAVE_I965_DRI, test x$HAVE_I965_DRI = xyes)