aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2014-07-11 18:00:29 +0200
committermarha <marha@users.sourceforge.net>2014-07-11 18:00:29 +0200
commite708bebcc029873004ade4241f347ce8c58896af (patch)
tree0b942757c1846afbe11e4158438981d6a645849d /mesalib/configure.ac
parentfe03d6aef6338e43593f164b09ae993bcd0ecbdd (diff)
downloadvcxsrv-e708bebcc029873004ade4241f347ce8c58896af.tar.gz
vcxsrv-e708bebcc029873004ade4241f347ce8c58896af.tar.bz2
vcxsrv-e708bebcc029873004ade4241f347ce8c58896af.zip
fontconfig libX11 xserver mkfontscale mesa git update 11 July 2014
xserver commit 9de3cc8daa4c6e877d30a0e8ccfe0cc159f1dbe3 libX11 commit ff9a5c199251a84fa59d14fd48dadb3f8920b54b mkfontscale commit 47908fd7a0d061fdcd21e3498da4e223ca9136d9 fontconfig commit dca5d0feee5eb6428bec48b1aff4396cf92c76c0 mesa commit f381c27c548aa28b003c8e188f5d627ab4105f76
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac16
1 files changed, 3 insertions, 13 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index 4646212be..48f5f815e 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -159,20 +159,13 @@ solaris*)
DEFINES="$DEFINES -DHAVE_PTHREAD -DSVR4"
;;
cygwin*)
- DEFINES="$DEFINES -DHAVE_PTHREAD"
+ DEFINES="$DEFINES -D_XOPEN_SOURCE=700 -DHAVE_PTHREAD"
;;
esac
dnl Add flags for gcc and g++
if test "x$GCC" = xyes; then
- case "$host_os" in
- cygwin*)
- CFLAGS="$CFLAGS -Wall -std=gnu99"
- ;;
- *)
- CFLAGS="$CFLAGS -Wall -std=c99"
- ;;
- esac
+ CFLAGS="$CFLAGS -Wall -std=c99"
# Enable -Werror=implicit-function-declaration and
# -Werror=missing-prototypes, if available, or otherwise, just
@@ -1992,7 +1985,7 @@ if test -n "$with_gallium_drivers"; then
fi
if test "x$enable_dri" = xyes; then
- GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS dri-swrast"
+ GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS dri/swrast"
fi
;;
*)
@@ -2196,8 +2189,6 @@ AC_CONFIG_FILES([Makefile
src/gallium/state_trackers/Makefile
src/gallium/state_trackers/clover/Makefile
src/gallium/state_trackers/dri/Makefile
- src/gallium/state_trackers/dri/drm/Makefile
- src/gallium/state_trackers/dri/sw/Makefile
src/gallium/state_trackers/egl/Makefile
src/gallium/state_trackers/gbm/Makefile
src/gallium/state_trackers/glx/xlib/Makefile
@@ -2208,7 +2199,6 @@ AC_CONFIG_FILES([Makefile
src/gallium/state_trackers/xa/Makefile
src/gallium/state_trackers/xvmc/Makefile
src/gallium/targets/Makefile
- src/gallium/targets/dri-swrast/Makefile
src/gallium/targets/dri/Makefile
src/gallium/targets/egl-static/Makefile
src/gallium/targets/gbm/Makefile