aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2011-11-07 07:15:44 +0100
committermarha <marha@users.sourceforge.net>2011-11-07 07:15:44 +0100
commit1ed503a856d9753a813951796bc6ba56c42ecd28 (patch)
tree9bd4e360a04dcb4b17d5ed3ac7e11b7225e5c4c2 /mesalib/configure.ac
parent02f377d5e2dd18537d0807ad63675a0970b5a37d (diff)
downloadvcxsrv-1ed503a856d9753a813951796bc6ba56c42ecd28.tar.gz
vcxsrv-1ed503a856d9753a813951796bc6ba56c42ecd28.tar.bz2
vcxsrv-1ed503a856d9753a813951796bc6ba56c42ecd28.zip
xserver pixman mesa git update 7 nov 2011
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index 30b3b96c3..8885a6d74 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -1052,7 +1052,7 @@ AC_SUBST([GLESv1_CM_PC_LIB_PRIV])
AC_SUBST([GLESv2_LIB_DEPS])
AC_SUBST([GLESv2_PC_LIB_PRIV])
-GLAPI_LIB_DEPS="-lpthread"
+GLAPI_LIB_DEPS="-lpthread $SELINUX_LIBS"
AC_SUBST([GLAPI_LIB_DEPS])
@@ -1427,8 +1427,8 @@ dnl
dnl gbm Gallium configuration
dnl
if test "x$enable_gallium_gbm" = xauto; then
- case "$enable_gbm$HAVE_ST_EGL$with_egl_platforms" in
- yesyes*drm*)
+ case "$enable_gbm$HAVE_ST_EGL$enable_dri$with_egl_platforms" in
+ yesyesyes*drm*)
enable_gallium_gbm=yes ;;
*)
enable_gallium_gbm=no ;;
@@ -1441,6 +1441,10 @@ if test "x$enable_gallium_gbm" = xyes; then
if test "x$enable_gbm" = xno; then
AC_MSG_ERROR([cannot enable gbm_gallium without gbm])
fi
+ # gbm_gallium abuses DRI_LIB_DEPS to link. Make sure it is set.
+ if test "x$enable_dri" = xno; then
+ AC_MSG_ERROR([gbm_gallium requires --enable-dri to build])
+ fi
GALLIUM_STATE_TRACKERS_DIRS="gbm $GALLIUM_STATE_TRACKERS_DIRS"
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS gbm"