aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2011-07-12 08:07:49 +0200
committermarha <marha@users.sourceforge.net>2011-07-12 08:07:49 +0200
commitf9f3118e6636a03c096898e023e7e13a328cbaed (patch)
tree2799648cd825202ce426fc1e55b235a8d9ebbb03 /mesalib/configure.ac
parent7a945c825829cbadecebc3723e96a786244b9971 (diff)
parent3b47b2c35227184c0eb6dcf6dee8b79c4f9d4474 (diff)
downloadvcxsrv-f9f3118e6636a03c096898e023e7e13a328cbaed.tar.gz
vcxsrv-f9f3118e6636a03c096898e023e7e13a328cbaed.tar.bz2
vcxsrv-f9f3118e6636a03c096898e023e7e13a328cbaed.zip
Merge remote-tracking branch 'origin/released'
Conflicts: mesalib/src/mesa/main/depthstencil.c mesalib/src/mesa/main/formats.c mesalib/src/mesa/state_tracker/st_cb_drawpixels.c
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index dde13c9b5..eace790d8 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -617,6 +617,13 @@ AC_ARG_WITH([gallium-drivers],
[with_gallium_drivers="$withval"],
[with_gallium_drivers="$GALLIUM_DRIVERS_DEFAULT"])
+# Doing '--without-gallium-drivers' will set this variable to 'no'. Clear it
+# here so that the script doesn't choke on an unknown driver name later.
+case "$with_gallium_drivers" in
+ yes) with_gallium_drivers="$GALLIUM_DRIVERS_DEFAULT" ;;
+ no) with_gallium_drivers='' ;;
+esac
+
if test "x$enable_opengl" = xno -a \
"x$enable_gles1" = xno -a \
"x$enable_gles2" = xno -a \
@@ -791,7 +798,7 @@ esac
if test "x$enable_dri" = xyes; then
DRIVER_DIRS="$DRIVER_DIRS dri"
- GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/xlib sw/dri"
+ GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/dri"
GALLIUM_STATE_TRACKERS_DIRS="dri $GALLIUM_STATE_TRACKERS_DIRS"
HAVE_ST_DRI="yes"
fi
@@ -1806,7 +1813,7 @@ fi
if test "x$enable_gallium_llvm" = xyes; then
if test "x$LLVM_CONFIG" != xno; then
LLVM_VERSION=`$LLVM_CONFIG --version`
- LLVM_CFLAGS=`$LLVM_CONFIG --cppflags`
+ LLVM_CFLAGS=`$LLVM_CONFIG --cppflags|sed 's/-DNDEBUG\>//g'`
LLVM_LIBS="`$LLVM_CONFIG --libs` -lstdc++"
LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`