aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2013-02-11 08:02:10 +0100
committermarha <marha@users.sourceforge.net>2013-02-11 08:02:10 +0100
commit8753441b3ba4316448e1ae5f408e6a84b0116a3c (patch)
tree8defe6bffed265e0846489015877f2384f022e67 /mesalib/configure.ac
parent212958ab41363d50d87470f6fb47bbcdc7a74c74 (diff)
downloadvcxsrv-8753441b3ba4316448e1ae5f408e6a84b0116a3c.tar.gz
vcxsrv-8753441b3ba4316448e1ae5f408e6a84b0116a3c.tar.bz2
vcxsrv-8753441b3ba4316448e1ae5f408e6a84b0116a3c.zip
xserver mesa git update 11 Feb 2013
xserver commit c1602d1c17967bdd4db9db19b3a9c0dfca6a58aa mesa commit 990bd49fba7d539e950bdda6eb9819a9abf14850
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac14
1 files changed, 10 insertions, 4 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index 6735fdcf0..d08bc2779 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -499,10 +499,16 @@ AC_CHECK_FUNC([dlopen], [DEFINES="$DEFINES -DHAVE_DLOPEN"],
[DEFINES="$DEFINES -DHAVE_DLOPEN"; DLOPEN_LIBS="-ldl"])])
AC_SUBST([DLOPEN_LIBS])
-AC_CHECK_FUNCS([clock_gettime], [CLOCK_LIB=],
- [AC_CHECK_LIB([rt], [clock_gettime], [CLOCK_LIB=-lrt],
- [AC_MSG_ERROR([Couldn't find clock_gettime])])])
-AC_SUBST([CLOCK_LIB])
+case "$host_os" in
+darwin*)
+ ;;
+*)
+ AC_CHECK_FUNCS([clock_gettime], [CLOCK_LIB=],
+ [AC_CHECK_LIB([rt], [clock_gettime], [CLOCK_LIB=-lrt],
+ [AC_MSG_ERROR([Couldn't find clock_gettime])])])
+ AC_SUBST([CLOCK_LIB])
+ ;;
+esac
dnl See if posix_memalign is available
AC_CHECK_FUNC([posix_memalign], [DEFINES="$DEFINES -DHAVE_POSIX_MEMALIGN"])