aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2011-06-14 08:12:46 +0200
committermarha <marha@users.sourceforge.net>2011-06-14 08:12:46 +0200
commit4d74e36f359d22b50302c82a922b79ac24dd3e23 (patch)
treefb8a1645c35cdbe7ac484fbd240c0c9993750b7c /mesalib/configure.ac
parentf4babb3a422e27cd33fba36f7a21eb67b7dee25d (diff)
downloadvcxsrv-4d74e36f359d22b50302c82a922b79ac24dd3e23.tar.gz
vcxsrv-4d74e36f359d22b50302c82a922b79ac24dd3e23.tar.bz2
vcxsrv-4d74e36f359d22b50302c82a922b79ac24dd3e23.zip
libxcb mesa xkeyboard-config git update 14 June 2011
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac34
1 files changed, 14 insertions, 20 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index 1e5f9cec9..69513c1c4 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -1741,6 +1741,14 @@ gallium_check_st() {
fi
}
+gallium_require_llvm() {
+ if test "x$MESA_LLVM" = x0; then
+ case "$host_cpu" in
+ i*86|x86_64) AC_MSG_ERROR([LLVM is required to build $1 on x86 and x86_64]);;
+ esac
+ fi
+}
+
dnl
dnl Gallium SVGA configuration
@@ -1793,30 +1801,16 @@ dnl
dnl Gallium Radeon r300g configuration
dnl
AC_ARG_ENABLE([gallium-r300],
- [AS_HELP_STRING([--enable-gallium-r300],
- [build gallium r300 @<:@default=build DRI driver only@:>@])],
+ [AS_HELP_STRING([--disable-gallium-r300],
+ [build R300 driver @<:@default=enabled@:>@])],
[enable_gallium_r300="$enableval"],
- [enable_gallium_r300=auto])
+ [enable_gallium_r300=yes])
-if test "$mesa_driver" != dri ; then
- if test "x$enable_gallium_r300" = xauto; then
- enable_gallium_r300=no
- fi
-fi
+if test "x$enable_gallium_r300" = xyes && test "x$mesa_driver" = xdri; then
+ gallium_require_llvm "Gallium R300"
-if test "x$enable_gallium_r300" != xno; then
- if test "x$MESA_LLVM" = x0; then
- case "$host_cpu" in
- i*86|x86_64) AC_MSG_ERROR([LLVM is required to build Gallium R300 on x86 and x86_64]);;
- esac
- fi
-fi
-if test "x$enable_gallium_r300" = xauto; then
- GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS r300"
- gallium_check_st "radeon/drm" "dri-r300"
-elif test "x$enable_gallium_r300" = xyes; then
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS r300"
- gallium_check_st "radeon/drm" "dri-r300" "xorg-radeon"
+ gallium_check_st "radeon/drm" "dri-r300" "xorg-r300"
fi
dnl