aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2011-05-03 12:48:26 +0000
committermarha <marha@users.sourceforge.net>2011-05-03 12:48:26 +0000
commitcc93496bdbb3e7aea51033ece75fa85cfb5845d4 (patch)
tree4346be8524d6ff90f89a403dc53c8519eacdf2e5 /mesalib/configure.ac
parent34f1ddbb272a5ad55f56d54e2f861da6360db04f (diff)
downloadvcxsrv-cc93496bdbb3e7aea51033ece75fa85cfb5845d4.tar.gz
vcxsrv-cc93496bdbb3e7aea51033ece75fa85cfb5845d4.tar.bz2
vcxsrv-cc93496bdbb3e7aea51033ece75fa85cfb5845d4.zip
xkeyboard libxcb pixman mesa git update 2 May 2011
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index 3b05ca353..54d9c2968 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -1784,6 +1784,13 @@ AC_ARG_ENABLE([gallium-r300],
[build gallium r300 @<:@default=build DRI driver only@:>@])],
[enable_gallium_r300="$enableval"],
[enable_gallium_r300=auto])
+
+if test "$mesa_driver" != dri ; then
+ if test "x$enable_gallium_r300" = xauto; then
+ enable_gallium_r300=no
+ fi
+fi
+
if test "x$enable_gallium_r300" != xno; then
if test "x$MESA_LLVM" = x0; then
case "$host_cpu" in