aboutsummaryrefslogtreecommitdiff
path: root/mesalib/docs/MESA_drm_image.spec
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2011-05-09 10:10:32 +0000
committermarha <marha@users.sourceforge.net>2011-05-09 10:10:32 +0000
commit5bb5135182a1a50b1b6659d8aa5168ebfbe71979 (patch)
tree7c8f16bf0832a90195bdbc4e8a9477158e0acf9b /mesalib/docs/MESA_drm_image.spec
parentc721bc9b176ec37d8b80a92c89840658f8f6c458 (diff)
parent43b2398ee28e9144fd51eb9994d67c4c9a198c9c (diff)
downloadvcxsrv-5bb5135182a1a50b1b6659d8aa5168ebfbe71979.tar.gz
vcxsrv-5bb5135182a1a50b1b6659d8aa5168ebfbe71979.tar.bz2
vcxsrv-5bb5135182a1a50b1b6659d8aa5168ebfbe71979.zip
svn merge ^/branches/released .
Diffstat (limited to 'mesalib/docs/MESA_drm_image.spec')
-rw-r--r--mesalib/docs/MESA_drm_image.spec18
1 files changed, 11 insertions, 7 deletions
diff --git a/mesalib/docs/MESA_drm_image.spec b/mesalib/docs/MESA_drm_image.spec
index 76de3f8b6..fa1e32e06 100644
--- a/mesalib/docs/MESA_drm_image.spec
+++ b/mesalib/docs/MESA_drm_image.spec
@@ -66,6 +66,7 @@ New Tokens
EGL_DRM_BUFFER_USE_SCANOUT_MESA 0x0001
EGL_DRM_BUFFER_USE_SHARE_MESA 0x0002
+ EGL_DRM_BUFFER_USE_CURSOR_MESA 0x0004
Accepted in the <target> parameter of eglCreateImageKHR:
@@ -89,13 +90,16 @@ Additions to the EGL 1.4 Specification:
extension is EGL_DRM_BUFFER_FORMAT_ARGB32_MESA, where each pixel
is a CPU-endian, 32-bit quantity, with alpha in the upper 8 bits,
then red, then green, then blue. The bit values accepted by
- EGL_DRM_BUFFER_USE_MESA are EGL_DRM_BUFFER_USE_SCANOUT_MESA and
- EGL_DRM_BUFFER_USE_SHARE_MESA. EGL_DRM_BUFFER_USE_SCANOUT_MESA
- requests that the created EGLImage should be usable as a scanout
- buffer with the DRM kernel modesetting API. The
- EGL_DRM_BUFFER_USE_SHARE_MESA bit requests that the EGLImage can
- be shared with other processes by passing the underlying DRM
- buffer name.
+ EGL_DRM_BUFFER_USE_MESA are EGL_DRM_BUFFER_USE_SCANOUT_MESA,
+ EGL_DRM_BUFFER_USE_SHARE_MESA and EGL_DRM_BUFFER_USE_CURSOR_MESA.
+ EGL_DRM_BUFFER_USE_SCANOUT_MESA requests that the created EGLImage
+ should be usable as a scanout buffer with the DRM kernel
+ modesetting API. EGL_DRM_BUFFER_USE_SHARE_MESA requests that the
+ EGLImage can be shared with other processes by passing the
+ underlying DRM buffer name. EGL_DRM_BUFFER_USE_CURSOR_MESA
+ requests that the image must be usable as a cursor with KMS. When
+ EGL_DRM_BUFFER_USE_CURSOR_MESA is set, width and height must both
+ be 64.
To create a process local handle or a global DRM name for a
buffer, call