aboutsummaryrefslogtreecommitdiff
path: root/mesalib/docs/specs/MESA_shader_integer_mix.spec
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2013-09-18 08:03:04 +0200
committermarha <marha@users.sourceforge.net>2013-09-18 08:03:04 +0200
commit7f669a708bd35bdf8e842f762ec68f9ad0ec0486 (patch)
tree332fc6d6e6f70503d717249e4e387bf3eea29637 /mesalib/docs/specs/MESA_shader_integer_mix.spec
parenta7d3f63ee5e292379ed6d6eba0c65512205a4786 (diff)
downloadvcxsrv-7f669a708bd35bdf8e842f762ec68f9ad0ec0486.tar.gz
vcxsrv-7f669a708bd35bdf8e842f762ec68f9ad0ec0486.tar.bz2
vcxsrv-7f669a708bd35bdf8e842f762ec68f9ad0ec0486.zip
libX11 mesa pixman xserver git update 18 Sep 2013
xserver commit 8010d3a48bd0b224dcb0883e39c2351ad364d846 libX11 commit 5dcb40f28d59587597d2ff6e6ac64c71cfe6ff7b pixman commit 58a79dfe6d1fd62c2b66c69fdb64f6b8ecf61da5 mesa commit a3b51a22f71819236baa6bbda9d0d050914b149d
Diffstat (limited to 'mesalib/docs/specs/MESA_shader_integer_mix.spec')
-rw-r--r--mesalib/docs/specs/MESA_shader_integer_mix.spec135
1 files changed, 0 insertions, 135 deletions
diff --git a/mesalib/docs/specs/MESA_shader_integer_mix.spec b/mesalib/docs/specs/MESA_shader_integer_mix.spec
deleted file mode 100644
index d381ddd43..000000000
--- a/mesalib/docs/specs/MESA_shader_integer_mix.spec
+++ /dev/null
@@ -1,135 +0,0 @@
-Name
-
- MESA_shader_integer_mix
-
-Name Strings
-
- GL_MESA_shader_integer_mix
-
-Contact
-
- Matt Turner (matt.turner 'at' intel.com)
-
-Contributors
-
- Matt Turner, Intel
- Ian Romanick, Intel
-
-Status
-
- Shipping
-
-Version
-
- Last Modified Date: 09/09/2013
- Author Revision: 5
-
-Number
-
-
-
-Dependencies
-
- OpenGL 3.0 or OpenGL ES 3.0 is required. This extension interacts with
- GL_ARB_ES3_compatibility.
-
- This extension is written against the OpenGL 4.4 (core) specification
- and the GLSL 4.40 specification.
-
-Overview
-
- GLSL 1.30 (and GLSL ES 3.00) expanded the mix() built-in function to
- operate on a boolean third argument that does not interpolate but
- selects. This extension extends mix() to select between int, uint,
- and bool components.
-
-New Procedures and Functions
-
- None.
-
-New Tokens
-
- None.
-
-Additions to Chapter 8 of the GLSL 4.40 Specification (Built-in Functions)
-
- Modify Section 8.3, Common Functions
-
- Additions to the table listing common built-in functions:
-
- Syntax Description
- --------------------------- --------------------------------------------------
- genIType mix(genIType x, Selects which vector each returned component comes
- genIType y, from. For a component of a that is false, the
- genBType a) corresponding component of x is returned. For a
- genUType mix(genUType x, component of a that is true, the corresponding
- genUType y, component of y is returned.
- genBType a)
- genBType mix(genBType x,
- genBType y,
- genBType a)
-
-Additions to the AGL/GLX/WGL Specifications
-
- None.
-
-Modifications to The OpenGL Shading Language Specification, Version 4.40
-
- Including the following line in a shader can be used to control the
- language features described in this extension:
-
- #extension GL_MESA_shader_integer_mix : <behavior>
-
- where <behavior> is as specified in section 3.3.
-
- New preprocessor #defines are added to the OpenGL Shading Language:
-
- #define GL_MESA_shader_integer_mix 1
-
-Interactions with ARB_ES3_compatibility
-
- On desktop implementations that support ARB_ES3_compatibility,
- GL_MESA_shader_integer_mix can be enabled (and the new functions
- used) in shaders declared with '#version 300 es'.
-
-GLX Protocol
-
- None.
-
-Errors
-
- None.
-
-New State
-
- None.
-
-New Implementation Dependent State
-
- None.
-
-Issues
-
- 1) Should we allow linear interpolation of integers via a non-boolean
- third component?
-
- RESOLVED: No.
-
- 2) Should we allow mix() to select between boolean components?
-
- RESOLVED: Yes. Implementing the same functionality using casts would be
- possible but ugly.
-
-Revision History
-
- Rev. Date Author Changes
- ---- -------- -------- ---------------------------------------------
- 5 09/09/2013 idr Add ARB_ES3_compatibility interaction.
-
- 4 09/06/2013 mattst88 Allow extension on OpenGL ES 3.0.
-
- 3 08/28/2013 mattst88 Add #extension/#define changes.
-
- 2 08/26/2013 mattst88 Change vendor prefix to MESA. Add mix() that
- selects between boolean components.
- 1 08/26/2013 mattst88 Initial revision