aboutsummaryrefslogtreecommitdiff
path: root/mesalib/src/gallium/auxiliary/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2013-01-11 08:22:46 +0100
committermarha <marha@users.sourceforge.net>2013-01-11 08:22:46 +0100
commit0e1adc84d471955eaabe26486154e8ec44e91dd4 (patch)
treee2363fb022bfa7b730b0032b4c35379aa2a997d6 /mesalib/src/gallium/auxiliary/Makefile.am
parente59b1896b907c5ecfe184723d4c6adc2c20fa678 (diff)
parentddc05759f098f06bd93253a7bffe38640963dfb3 (diff)
downloadvcxsrv-0e1adc84d471955eaabe26486154e8ec44e91dd4.tar.gz
vcxsrv-0e1adc84d471955eaabe26486154e8ec44e91dd4.tar.bz2
vcxsrv-0e1adc84d471955eaabe26486154e8ec44e91dd4.zip
Merge remote-tracking branch 'origin/released'
* origin/released: fontconfig libX11 mesa mkfontscale xserver git update 11 jan 2013 Conflicts: mesalib/src/glsl/.gitignore mesalib/src/glsl/glcpp/.gitignore mesalib/src/mapi/glapi/gen/.gitignore mesalib/src/mesa/program/.gitignore
Diffstat (limited to 'mesalib/src/gallium/auxiliary/Makefile.am')
-rw-r--r--mesalib/src/gallium/auxiliary/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/mesalib/src/gallium/auxiliary/Makefile.am b/mesalib/src/gallium/auxiliary/Makefile.am
new file mode 100644
index 000000000..b8ac7c9dd
--- /dev/null
+++ b/mesalib/src/gallium/auxiliary/Makefile.am
@@ -0,0 +1,51 @@
+AUTOMAKE_OPTIONS = subdir-objects
+
+include Makefile.sources
+include $(top_srcdir)/src/gallium/Automake.inc
+
+noinst_LTLIBRARIES = libgallium.la
+
+AM_CFLAGS = \
+ -I$(top_srcdir)/src/gallium/auxiliary/util \
+ $(GALLIUM_CFLAGS)
+
+libgallium_la_SOURCES = \
+ $(C_SOURCES) \
+ $(GENERATED_SOURCES)
+
+if HAVE_MESA_LLVM
+
+AM_CFLAGS += \
+ $(LLVM_CFLAGS)
+
+AM_CXXFLAGS = \
+ $(GALLIUM_CFLAGS) \
+ $(LLVM_CXXFLAGS)
+
+if LLVM_NEEDS_FNORTTI
+
+AM_CXXFLAGS += -fno-rtti
+
+endif
+
+libgallium_la_SOURCES += \
+ $(GALLIVM_SOURCES) \
+ $(GALLIVM_CPP_SOURCES)
+
+endif
+
+indices/u_indices_gen.c: $(srcdir)/indices/u_indices_gen.py
+ $(AM_V_GEN) $(PYTHON2) $< > $@
+
+indices/u_unfilled_gen.c: $(srcdir)/indices/u_unfilled_gen.py
+ $(AM_V_GEN) $(PYTHON2) $< > $@
+
+util/u_format_srgb.c: $(srcdir)/util/u_format_srgb.py
+ $(AM_V_GEN) $(PYTHON2) $< > $@
+
+util/u_format_table.c: $(srcdir)/util/u_format_table.py $(srcdir)/util/u_format_pack.py $(srcdir)/util/u_format_parse.py $(srcdir)/util/u_format.csv
+ $(AM_V_GEN) $(PYTHON2) $(srcdir)/util/u_format_table.py $(srcdir)/util/u_format.csv > $@
+
+#XXX: Delete this when all targets are converted to automake.
+all-local: libgallium.la
+ ln -f $(builddir)/.libs/libgallium.a $(builddir)/libgallium.a