aboutsummaryrefslogtreecommitdiff
path: root/mesalib/src/gallium/auxiliary/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2013-01-11 08:00:45 +0100
committermarha <marha@users.sourceforge.net>2013-01-11 08:00:45 +0100
commitddc05759f098f06bd93253a7bffe38640963dfb3 (patch)
treefd0ae943233033cda2bfe50dd097532a4cf5c0b9 /mesalib/src/gallium/auxiliary/Makefile.am
parent8a26872f0c9102cb357345eca24a4bf7401bbe70 (diff)
downloadvcxsrv-ddc05759f098f06bd93253a7bffe38640963dfb3.tar.gz
vcxsrv-ddc05759f098f06bd93253a7bffe38640963dfb3.tar.bz2
vcxsrv-ddc05759f098f06bd93253a7bffe38640963dfb3.zip
fontconfig libX11 mesa mkfontscale xserver git update 11 jan 2013
fontconfig: 0831c1770e4bac7269a190936bbb0529d747e233 libX11: 0b148750027fd0557c5ed93afda861ddf4b92e0f mkfontscale: 9cbe3256bc932b82f2435b23cda0931f4f5f5ba2 xserver: 6703a7c7cf1a349c137e247a0c8eb462ff7b07be mesa: babab2876080af0fe65249dff559244aebd0b87e
Diffstat (limited to 'mesalib/src/gallium/auxiliary/Makefile.am')
-rw-r--r--mesalib/src/gallium/auxiliary/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/mesalib/src/gallium/auxiliary/Makefile.am b/mesalib/src/gallium/auxiliary/Makefile.am
new file mode 100644
index 000000000..b8ac7c9dd
--- /dev/null
+++ b/mesalib/src/gallium/auxiliary/Makefile.am
@@ -0,0 +1,51 @@
+AUTOMAKE_OPTIONS = subdir-objects
+
+include Makefile.sources
+include $(top_srcdir)/src/gallium/Automake.inc
+
+noinst_LTLIBRARIES = libgallium.la
+
+AM_CFLAGS = \
+ -I$(top_srcdir)/src/gallium/auxiliary/util \
+ $(GALLIUM_CFLAGS)
+
+libgallium_la_SOURCES = \
+ $(C_SOURCES) \
+ $(GENERATED_SOURCES)
+
+if HAVE_MESA_LLVM
+
+AM_CFLAGS += \
+ $(LLVM_CFLAGS)
+
+AM_CXXFLAGS = \
+ $(GALLIUM_CFLAGS) \
+ $(LLVM_CXXFLAGS)
+
+if LLVM_NEEDS_FNORTTI
+
+AM_CXXFLAGS += -fno-rtti
+
+endif
+
+libgallium_la_SOURCES += \
+ $(GALLIVM_SOURCES) \
+ $(GALLIVM_CPP_SOURCES)
+
+endif
+
+indices/u_indices_gen.c: $(srcdir)/indices/u_indices_gen.py
+ $(AM_V_GEN) $(PYTHON2) $< > $@
+
+indices/u_unfilled_gen.c: $(srcdir)/indices/u_unfilled_gen.py
+ $(AM_V_GEN) $(PYTHON2) $< > $@
+
+util/u_format_srgb.c: $(srcdir)/util/u_format_srgb.py
+ $(AM_V_GEN) $(PYTHON2) $< > $@
+
+util/u_format_table.c: $(srcdir)/util/u_format_table.py $(srcdir)/util/u_format_pack.py $(srcdir)/util/u_format_parse.py $(srcdir)/util/u_format.csv
+ $(AM_V_GEN) $(PYTHON2) $(srcdir)/util/u_format_table.py $(srcdir)/util/u_format.csv > $@
+
+#XXX: Delete this when all targets are converted to automake.
+all-local: libgallium.la
+ ln -f $(builddir)/.libs/libgallium.a $(builddir)/libgallium.a