aboutsummaryrefslogtreecommitdiff
path: root/mesalib/src/glsl/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2014-05-11 17:43:25 +0200
committermarha <marha@users.sourceforge.net>2014-05-11 17:43:25 +0200
commit26dfcdba6c306d6312c598e4191449302329be68 (patch)
tree2bf56b5a0eb2cc554833fdc6e08f2b59f1bfdabd /mesalib/src/glsl/Makefile.am
parent2dc2880eacae3d52f4ab4bb5ec43c5bbf50c5c3f (diff)
parentae06feae7876db47ff0e1fde40cf4a324a412037 (diff)
downloadvcxsrv-26dfcdba6c306d6312c598e4191449302329be68.tar.gz
vcxsrv-26dfcdba6c306d6312c598e4191449302329be68.tar.bz2
vcxsrv-26dfcdba6c306d6312c598e4191449302329be68.zip
Merge remote-tracking branch 'origin/released'
Conflicts: mesalib/src/mesa/main/imports.h
Diffstat (limited to 'mesalib/src/glsl/Makefile.am')
-rw-r--r--mesalib/src/glsl/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/mesalib/src/glsl/Makefile.am b/mesalib/src/glsl/Makefile.am
index 534eaa385..fd0e837d1 100644
--- a/mesalib/src/glsl/Makefile.am
+++ b/mesalib/src/glsl/Makefile.am
@@ -61,7 +61,9 @@ tests_general_ir_test_SOURCES = \
$(GLSL_SRCDIR)/standalone_scaffolding.cpp \
tests/builtin_variable_test.cpp \
tests/invalidate_locations_test.cpp \
- tests/general_ir_test.cpp
+ tests/general_ir_test.cpp \
+ tests/varyings_test.cpp \
+ tests/common.c
tests_general_ir_test_CFLAGS = \
$(PTHREAD_CFLAGS)
tests_general_ir_test_LDADD = \
@@ -76,7 +78,8 @@ tests_uniform_initializer_test_SOURCES = \
$(top_srcdir)/src/mesa/program/symbol_table.c \
tests/copy_constant_to_storage_tests.cpp \
tests/set_uniform_initializer_tests.cpp \
- tests/uniform_initializer_utils.cpp
+ tests/uniform_initializer_utils.cpp \
+ tests/common.c
tests_uniform_initializer_test_CFLAGS = \
$(PTHREAD_CFLAGS)
tests_uniform_initializer_test_LDADD = \
@@ -95,7 +98,8 @@ tests_ralloc_test_LDADD = \
tests_sampler_types_test_SOURCES = \
$(top_srcdir)/src/mesa/program/prog_hash_table.c\
$(top_srcdir)/src/mesa/program/symbol_table.c \
- tests/sampler_types_test.cpp
+ tests/sampler_types_test.cpp \
+ tests/common.c
tests_sampler_types_test_CFLAGS = \
$(PTHREAD_CFLAGS)
tests_sampler_types_test_LDADD = \
@@ -138,6 +142,7 @@ glsl_test_SOURCES = \
$(top_srcdir)/src/mesa/program/prog_hash_table.c \
$(top_srcdir)/src/mesa/program/symbol_table.c \
$(GLSL_SRCDIR)/standalone_scaffolding.cpp \
+ tests/common.c \
test.cpp \
test_optpass.cpp