aboutsummaryrefslogtreecommitdiff
path: root/mesalib/src/glsl/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2013-10-24 08:15:59 +0200
committermarha <marha@users.sourceforge.net>2013-10-24 08:15:59 +0200
commit285b1bd8933288fc56259cfb3de61207c8e35d9e (patch)
tree2107aaa7f683f16a9a1a73e5f6f2d7ba53710f32 /mesalib/src/glsl/Makefile.am
parentc665b6e88274f8bc603b0f14f92bf09d2023bd4d (diff)
parent4eb0b643ad978d94837e2d587a5d4358f974a25c (diff)
downloadvcxsrv-285b1bd8933288fc56259cfb3de61207c8e35d9e.tar.gz
vcxsrv-285b1bd8933288fc56259cfb3de61207c8e35d9e.tar.bz2
vcxsrv-285b1bd8933288fc56259cfb3de61207c8e35d9e.zip
Merge remote-tracking branch 'origin/released'
* origin/released: fontconfig mesa xserver git update 24 oct 2013 Conflicts: xorg-server/glx/glxdricommon.c
Diffstat (limited to 'mesalib/src/glsl/Makefile.am')
-rw-r--r--mesalib/src/glsl/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/mesalib/src/glsl/Makefile.am b/mesalib/src/glsl/Makefile.am
index cbf253cb5..b9ed5b62b 100644
--- a/mesalib/src/glsl/Makefile.am
+++ b/mesalib/src/glsl/Makefile.am
@@ -32,6 +32,7 @@ AM_CXXFLAGS = $(VISIBILITY_CXXFLAGS)
include Makefile.sources
TESTS = glcpp/tests/glcpp-test \
+ tests/general-ir-test \
tests/optimization-test \
tests/ralloc-test \
tests/sampler-types-test \
@@ -45,12 +46,29 @@ noinst_LTLIBRARIES = libglsl.la libglcpp.la
check_PROGRAMS = \
glcpp/glcpp \
glsl_test \
+ tests/general-ir-test \
tests/ralloc-test \
tests/sampler-types-test \
tests/uniform-initializer-test
noinst_PROGRAMS = glsl_compiler
+tests_general_ir_test_SOURCES = \
+ $(top_srcdir)/src/mesa/main/hash_table.c \
+ $(top_srcdir)/src/mesa/main/imports.c \
+ $(top_srcdir)/src/mesa/program/prog_hash_table.c\
+ $(top_srcdir)/src/mesa/program/symbol_table.c \
+ $(GLSL_SRCDIR)/standalone_scaffolding.cpp \
+ tests/builtin_variable_test.cpp \
+ tests/invalidate_locations_test.cpp \
+ tests/general_ir_test.cpp
+tests_general_ir_test_CFLAGS = \
+ $(PTHREAD_CFLAGS)
+tests_general_ir_test_LDADD = \
+ $(top_builddir)/src/gtest/libgtest.la \
+ $(top_builddir)/src/glsl/libglsl.la \
+ $(PTHREAD_LIBS)
+
tests_uniform_initializer_test_SOURCES = \
$(top_srcdir)/src/mesa/main/hash_table.c \
$(top_srcdir)/src/mesa/main/imports.c \