aboutsummaryrefslogtreecommitdiff
path: root/mesalib/src/mesa/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2012-10-11 10:09:13 +0200
committermarha <marha@users.sourceforge.net>2012-10-11 10:09:13 +0200
commit30c05ead4fe1b6a341d5b585e3a6b5d255edf650 (patch)
tree932b22aede860e3ab2efe50116ad776f81c04606 /mesalib/src/mesa/Makefile.am
parentac799961eb382e48c68ffda1e1a89b346eb97f81 (diff)
parent8223fb176264123c86c0d3eb845973d00fd62cc2 (diff)
downloadvcxsrv-30c05ead4fe1b6a341d5b585e3a6b5d255edf650.tar.gz
vcxsrv-30c05ead4fe1b6a341d5b585e3a6b5d255edf650.tar.bz2
vcxsrv-30c05ead4fe1b6a341d5b585e3a6b5d255edf650.zip
Merge remote-tracking branch 'origin/released'
* origin/released: xwininfo mesa git update 11 oct 2012 Conflicts: mesalib/src/mapi/glapi/gen/glX_proto_recv.py mesalib/src/mapi/glapi/gen/glX_proto_size.py mesalib/src/mapi/glapi/gen/glX_server_table.py mesalib/src/mapi/glapi/gen/gl_table.py mesalib/src/mesa/main/.gitignore
Diffstat (limited to 'mesalib/src/mesa/Makefile.am')
-rw-r--r--mesalib/src/mesa/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/mesalib/src/mesa/Makefile.am b/mesalib/src/mesa/Makefile.am
index feec1070d..1dc3132c7 100644
--- a/mesalib/src/mesa/Makefile.am
+++ b/mesalib/src/mesa/Makefile.am
@@ -56,6 +56,7 @@ BUILT_SOURCES = \
main/api_exec_es1_dispatch.h \
main/api_exec_es1_remap_helper.h \
main/api_exec_es1.c \
+ main/get_hash.h \
program/program_parse.tab.c \
program/program_parse.tab.h \
program/lex.yy.c
@@ -83,6 +84,17 @@ program/lex.yy.c: program/program_lexer.l
$(MKDIR_P) program
$(AM_V_GEN) $(LEX) --never-interactive --outfile=$@ $<
+GET_HASH_GEN = main/get_hash_generator.py
+GET_HASH_GEN_FLAGS := $(patsubst -DFEATURE_%=1,-a %, \
+ $(patsubst -DFEATURE_%=0,,$(API_DEFINES)))
+
+main/get_hash.h: $(GLAPI)/gl_and_es_API.xml main/get_hash_params.py \
+ $(GET_HASH_GEN) Makefile
+ $(AM_V_GEN)set -e; \
+ $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/$(GET_HASH_GEN) \
+ $(GET_HASH_GEN_FLAGS) -f $< > $@.tmp; \
+ mv $@.tmp $@;
+
noinst_LTLIBRARIES =
if NEED_LIBMESA
noinst_LTLIBRARIES += libmesa.la