aboutsummaryrefslogtreecommitdiff
path: root/mesalib/src/mesa/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2012-07-04 10:41:31 +0200
committermarha <marha@users.sourceforge.net>2012-07-04 10:41:31 +0200
commitb3daaeb1467f3d3d52bef2f76413f3a063fc4f33 (patch)
tree4415e903a15dff8b36bba9fcce197d26a7790186 /mesalib/src/mesa/Makefile.am
parente44d0067ca65d58f258e7f2ae1a240c9bfce5766 (diff)
parentfc8f37239f3af088819c18f5632b2608954af73a (diff)
downloadvcxsrv-b3daaeb1467f3d3d52bef2f76413f3a063fc4f33.tar.gz
vcxsrv-b3daaeb1467f3d3d52bef2f76413f3a063fc4f33.tar.bz2
vcxsrv-b3daaeb1467f3d3d52bef2f76413f3a063fc4f33.zip
Merge remote-tracking branch 'origin/released'
Conflicts: xorg-server/include/misc.h xorg-server/os/utils.c
Diffstat (limited to 'mesalib/src/mesa/Makefile.am')
-rw-r--r--mesalib/src/mesa/Makefile.am14
1 files changed, 9 insertions, 5 deletions
diff --git a/mesalib/src/mesa/Makefile.am b/mesalib/src/mesa/Makefile.am
index e52678d58..bada7601a 100644
--- a/mesalib/src/mesa/Makefile.am
+++ b/mesalib/src/mesa/Makefile.am
@@ -78,25 +78,29 @@ main/api_exec_es2_remap_helper.h: $(GLAPI)/gl_and_es_API.xml $(glapi_gen_remap_d
main/api_exec_es2.o: main/api_exec_es2_dispatch.h main/api_exec_es2_remap_helper.h
main/api_exec_es1.c: main/APIspec.xml main/es_generator.py main/APIspecutil.py main/APIspec.py
- $(PYTHON2) $(PYTHON_FLAGS) main/es_generator.py -S main/APIspec.xml -V GLES1.1 > $@
+ $(PYTHON2) $(PYTHON_FLAGS) main/es_generator.py \
+ -S $(srcdir)/main/APIspec.xml -V GLES1.1 > $@
main/api_exec_es2.c: main/APIspec.xml main/es_generator.py main/APIspecutil.py main/APIspec.py
- $(PYTHON2) $(PYTHON_FLAGS) main/es_generator.py -S main/APIspec.xml -V GLES2.0 > $@
+ $(PYTHON2) $(PYTHON_FLAGS) main/es_generator.py \
+ -S $(srcdir)/main/APIspec.xml -V GLES2.0 > $@
program/program_parse.tab.c program/program_parse.tab.h: program/program_parse.y
+ mkdir -p program
$(YACC) -v -d --output=program/program_parse.tab.c $<
program/lex.yy.c: program/program_lexer.l
+ mkdir -p program
$(LEX) --never-interactive --outfile=$@ $<
all-local:
- $(MAKE) -f Makefile.old
+ $(MAKE) -f $(srcdir)/Makefile.old
install-exec-local:
- $(MAKE) -f Makefile.old install
+ $(MAKE) -f $(srcdir)/Makefile.old install
clean-local:
- $(MAKE) -f Makefile.old clean
+ $(MAKE) -f $(srcdir)/Makefile.old clean
pkgconfigdir = $(libdir)/pkgconfig