aboutsummaryrefslogtreecommitdiff
path: root/mesalib/src/mesa/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2012-10-11 08:30:47 +0200
committermarha <marha@users.sourceforge.net>2012-10-11 08:30:47 +0200
commit8223fb176264123c86c0d3eb845973d00fd62cc2 (patch)
tree1e6e73574f4025c542347d1fe023684619b65698 /mesalib/src/mesa/Makefile.am
parent8c5587d9be904856f7e449a144c2819a8e310599 (diff)
downloadvcxsrv-8223fb176264123c86c0d3eb845973d00fd62cc2.tar.gz
vcxsrv-8223fb176264123c86c0d3eb845973d00fd62cc2.tar.bz2
vcxsrv-8223fb176264123c86c0d3eb845973d00fd62cc2.zip
xwininfo mesa git update 11 oct 2012
xwininfo: f7b55bdf674fc790e879a2e25ef83925dd8379d6 mesa: 34c58acb59bc0b827e28ef9e89044621ab0b3ee1
Diffstat (limited to 'mesalib/src/mesa/Makefile.am')
-rw-r--r--mesalib/src/mesa/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/mesalib/src/mesa/Makefile.am b/mesalib/src/mesa/Makefile.am
index feec1070d..1dc3132c7 100644
--- a/mesalib/src/mesa/Makefile.am
+++ b/mesalib/src/mesa/Makefile.am
@@ -56,6 +56,7 @@ BUILT_SOURCES = \
main/api_exec_es1_dispatch.h \
main/api_exec_es1_remap_helper.h \
main/api_exec_es1.c \
+ main/get_hash.h \
program/program_parse.tab.c \
program/program_parse.tab.h \
program/lex.yy.c
@@ -83,6 +84,17 @@ program/lex.yy.c: program/program_lexer.l
$(MKDIR_P) program
$(AM_V_GEN) $(LEX) --never-interactive --outfile=$@ $<
+GET_HASH_GEN = main/get_hash_generator.py
+GET_HASH_GEN_FLAGS := $(patsubst -DFEATURE_%=1,-a %, \
+ $(patsubst -DFEATURE_%=0,,$(API_DEFINES)))
+
+main/get_hash.h: $(GLAPI)/gl_and_es_API.xml main/get_hash_params.py \
+ $(GET_HASH_GEN) Makefile
+ $(AM_V_GEN)set -e; \
+ $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/$(GET_HASH_GEN) \
+ $(GET_HASH_GEN_FLAGS) -f $< > $@.tmp; \
+ mv $@.tmp $@;
+
noinst_LTLIBRARIES =
if NEED_LIBMESA
noinst_LTLIBRARIES += libmesa.la