aboutsummaryrefslogtreecommitdiff
path: root/pixman/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2010-12-19 17:44:53 +0000
committermarha <marha@users.sourceforge.net>2010-12-19 17:44:53 +0000
commitb24af6c6af003368ebb5c3e042db0ab7a295d89e (patch)
tree264d7e2272a674e3c4a6034d127cbc95def12725 /pixman/configure.ac
parentf851244b9298d88c29331ab285c2839d8bee6925 (diff)
downloadvcxsrv-b24af6c6af003368ebb5c3e042db0ab7a295d89e.tar.gz
vcxsrv-b24af6c6af003368ebb5c3e042db0ab7a295d89e.tar.bz2
vcxsrv-b24af6c6af003368ebb5c3e042db0ab7a295d89e.zip
libXext libXdmcp pixman git update 29/12/2010
Diffstat (limited to 'pixman/configure.ac')
-rw-r--r--pixman/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/pixman/configure.ac b/pixman/configure.ac
index 683e6aabe..ac0d16158 100644
--- a/pixman/configure.ac
+++ b/pixman/configure.ac
@@ -639,6 +639,14 @@ if test x$have_getpagesize = xyes; then
AC_DEFINE(HAVE_GETPAGESIZE, 1, [Whether we have getpagesize()])
fi
+AC_CHECK_HEADER([fenv.h],
+ [AC_DEFINE(HAVE_FENV_H, [1], [Define to 1 if we have <fenv.h>])])
+
+AC_CHECK_LIB(m, feenableexcept, have_feenableexcept=yes, have_feenableexcept=no)
+if test x$have_feenableexcept = xyes; then
+ AC_DEFINE(HAVE_FEENABLEEXCEPT, 1, [Whether we have feenableexcept()])
+fi
+
AC_CHECK_FUNC(gettimeofday, have_gettimeofday=yes, have_gettimeofday=no)
AC_CHECK_HEADER(sys/time.h, have_sys_time_h=yes, have_sys_time_h=no)
if test x$have_gettimeofday = xyes && test x$have_sys_time_h = xyes; then