aboutsummaryrefslogtreecommitdiff
path: root/pixman/test/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2009-07-25 16:02:10 +0000
committermarha <marha@users.sourceforge.net>2009-07-25 16:02:10 +0000
commit6aa791a05508dd822b229cd4ff4f9b8cdd617db3 (patch)
treea07d0a8452c90e3305417e8691d6e1deca7aa9aa /pixman/test/Makefile.am
parentddfb922180a6a847d52609592a2bdb37179ca439 (diff)
parent4b195776d5fb64e83a4e56627367d8e9ea10cbf7 (diff)
downloadvcxsrv-6aa791a05508dd822b229cd4ff4f9b8cdd617db3.tar.gz
vcxsrv-6aa791a05508dd822b229cd4ff4f9b8cdd617db3.tar.bz2
vcxsrv-6aa791a05508dd822b229cd4ff4f9b8cdd617db3.zip
svn merge file:///D:/svnrepos/vcxsrv/branches/released .
Diffstat (limited to 'pixman/test/Makefile.am')
-rw-r--r--pixman/test/Makefile.am65
1 files changed, 55 insertions, 10 deletions
diff --git a/pixman/test/Makefile.am b/pixman/test/Makefile.am
index 33e2200db..324cb723d 100644
--- a/pixman/test/Makefile.am
+++ b/pixman/test/Makefile.am
@@ -1,19 +1,64 @@
-if HAVE_GTK
+TEST_LDADD = $(top_builddir)/pixman/libpixman-1.la
+INCLUDES = -I$(top_srcdir)/pixman -I$(top_builddir)/pixman
+
TESTPROGRAMS = \
+ region-test \
+ scaling-test \
+ fetch-test \
+ oob-test \
+ window-test \
+ trap-crasher
+
+fetch_test_LDADD = $(TEST_LDADD)
+region_test_LDADD = $(TEST_LDADD)
+scaling_test_LDADD = $(TEST_LDADD)
+trap_crasher_LDADD = $(TEST_LDADD)
+oob_test_LDADD = $(TEST_LDADD)
+window_test_LDADD = $(TEST_LDADD)
+
+# GTK using test programs
+
+if HAVE_GTK
+
+GTK_LDADD = $(TEST_LDADD) $(GTK_LIBS)
+
+TESTPROGRAMS += \
clip-test \
+ clip-in \
composite-test \
gradient-test \
- region-test \
- fetch-test
+ alpha-test \
+ screen-test \
+ convolution-test \
+ trap-test
-noinst_PROGRAMS = $(TESTPROGRAMS)
+INCLUDES += $(GTK_CFLAGS)
+
+gradient_test_LDADD = $(GTK_LDADD)
+gradient_test_SOURCES = gradient-test.c utils.c utils.h
+
+alpha_test_LDADD = $(GTK_LDADD)
+alpha_test_SOURCES = alpha-test.c utils.c utils.h
+
+composite_test_LDADD = $(GTK_LDADD)
+composite_test_SOURCES = composite-test.c utils.c utils.h
+
+clip_test_LDADD = $(GTK_LDADD)
+clip_test_SOURCES = clip-test.c utils.c utils.h
-INCLUDES = -I$(top_srcdir)/pixman -I$(top_builddir)/pixman $(GTK_CFLAGS)
+clip_in_LDADD = $(GTK_LDADD)
+clip_in_SOURCES = clip-in.c utils.c utils.h
-composite_test_LDADD = $(top_builddir)/pixman/libpixman-1.la $(GTK_LIBS)
-gradient_test_LDADD = $(top_builddir)/pixman/libpixman-1.la $(GTK_LIBS)
-fetch_test_LDADD = $(top_builddir)/pixman/libpixman-1.la
-region_test_LDADD = $(top_builddir)/pixman/libpixman-1.la
-clip_test_LDADD = $(top_builddir)/pixman/libpixman-1.la $(GTK_LIBS)
+trap_test_LDADD = $(GTK_LDADD)
+trap_test_SOURCES = trap-test.c utils.c utils.h
+
+screen_test_LDADD = $(GTK_LDADD)
+screen_test_SOURCES = screen-test.c utils.c utils.h
+
+convolution_test_LDADD = $(GTK_LDADD)
+convolution_test_SOURCES = convolution-test.c utils.c utils.h
endif
+
+noinst_PROGRAMS = $(TESTPROGRAMS)
+