aboutsummaryrefslogtreecommitdiff
path: root/pixman/test/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2010-01-19 23:10:44 +0000
committermarha <marha@users.sourceforge.net>2010-01-19 23:10:44 +0000
commita9768b035f2c47be0908520474073cc68d225d8a (patch)
treef9894781b3f1d5b36d5a5fa284c82ad36c9cf917 /pixman/test/Makefile.am
parentb152ebf4b66368e1cbfda1ae81cef29bf9c00bb7 (diff)
downloadvcxsrv-a9768b035f2c47be0908520474073cc68d225d8a.tar.gz
vcxsrv-a9768b035f2c47be0908520474073cc68d225d8a.tar.bz2
vcxsrv-a9768b035f2c47be0908520474073cc68d225d8a.zip
Updated to:
libX11-1.3.3 pixman-0.17.4
Diffstat (limited to 'pixman/test/Makefile.am')
-rw-r--r--pixman/test/Makefile.am21
1 files changed, 14 insertions, 7 deletions
diff --git a/pixman/test/Makefile.am b/pixman/test/Makefile.am
index 89d32e96f..5f6ba13ac 100644
--- a/pixman/test/Makefile.am
+++ b/pixman/test/Makefile.am
@@ -3,13 +3,14 @@ INCLUDES = -I$(top_srcdir)/pixman -I$(top_builddir)/pixman
TESTPROGRAMS = \
region-test \
- scaling-test \
- blitters-test \
- composite \
fetch-test \
oob-test \
window-test \
- trap-crasher
+ trap-crasher \
+ alphamap \
+ blitters-test \
+ scaling-test \
+ composite
fetch_test_LDADD = $(TEST_LDADD)
region_test_LDADD = $(TEST_LDADD)
@@ -24,6 +25,9 @@ blitters_test_SOURCES = blitters-test.c utils.c utils.h
scaling_test_LDADD = $(TEST_LDADD)
scaling_test_SOURCES = scaling-test.c utils.c utils.h
+alphamap_LDADD = $(TEST_LDADD)
+alphamap_SOURCES = alphamap.c utils.c utils.h
+
# GTK using test programs
if HAVE_GTK
@@ -31,7 +35,7 @@ if HAVE_GTK
GTK_LDADD = $(TEST_LDADD) $(GTK_LIBS)
GTK_UTILS = gtk-utils.c gtk-utils.h
-TESTPROGRAMS += \
+TESTPROGRAMS_GTK = \
clip-test \
clip-in \
composite-test \
@@ -39,7 +43,8 @@ TESTPROGRAMS += \
alpha-test \
screen-test \
convolution-test \
- trap-test
+ trap-test \
+ alphamap
INCLUDES += $(GTK_CFLAGS)
@@ -69,5 +74,7 @@ convolution_test_SOURCES = convolution-test.c $(GTK_UTILS)
endif
-noinst_PROGRAMS = $(TESTPROGRAMS)
+noinst_PROGRAMS = $(TESTPROGRAMS) $(TESTPROGRAMS_GTK)
+
+TESTS = $(TESTPROGRAMS)