aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/fb/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2010-06-11 12:14:52 +0000
committermarha <marha@users.sourceforge.net>2010-06-11 12:14:52 +0000
commit4c61bf84b11e26e6f22648668c95ea760a379163 (patch)
tree0ac762ab2815eae283dded7447ad7cb5a54b926a /xorg-server/fb/Makefile.am
parente1dabd2ce8be0d70c6c15353b58de256129dfd1f (diff)
downloadvcxsrv-4c61bf84b11e26e6f22648668c95ea760a379163.tar.gz
vcxsrv-4c61bf84b11e26e6f22648668c95ea760a379163.tar.bz2
vcxsrv-4c61bf84b11e26e6f22648668c95ea760a379163.zip
xserver git update 11/6/2010
Diffstat (limited to 'xorg-server/fb/Makefile.am')
-rw-r--r--xorg-server/fb/Makefile.am114
1 files changed, 58 insertions, 56 deletions
diff --git a/xorg-server/fb/Makefile.am b/xorg-server/fb/Makefile.am
index 64e49f345..21ed7b624 100644
--- a/xorg-server/fb/Makefile.am
+++ b/xorg-server/fb/Makefile.am
@@ -1,56 +1,58 @@
-noinst_LTLIBRARIES = libfb.la libwfb.la
-
-INCLUDES = \
- -I$(top_srcdir)/hw/xfree86/os-support \
- -I$(top_srcdir)/hw/xfree86/os-support/bus \
- -I$(top_srcdir)/hw/xfree86/common
-AM_CFLAGS = $(DIX_CFLAGS)
-
-if XORG
-sdk_HEADERS = fb.h fbrop.h fboverlay.h wfbrename.h fbpict.h
-endif
-
-libfb_la_CFLAGS = $(AM_CFLAGS)
-
-libwfb_la_CFLAGS = $(AM_CFLAGS) -DFB_ACCESS_WRAPPER
-
-libfb_la_SOURCES = \
- fb.h \
- fb24_32.c \
- fb24_32.h \
- fballpriv.c \
- fbarc.c \
- fbbits.c \
- fbbits.h \
- fbblt.c \
- fbbltone.c \
- fbcopy.c \
- fbfill.c \
- fbfillrect.c \
- fbfillsp.c \
- fbgc.c \
- fbgetsp.c \
- fbglyph.c \
- fbimage.c \
- fbline.c \
- fboverlay.c \
- fboverlay.h \
- fbpict.c \
- fbpict.h \
- fbpixmap.c \
- fbpoint.c \
- fbpush.c \
- fbrop.h \
- fbscreen.c \
- fbseg.c \
- fbsetsp.c \
- fbsolid.c \
- fbstipple.c \
- fbtile.c \
- fbtrap.c \
- fbutil.c \
- fbwindow.c
-
-libwfb_la_SOURCES = $(libfb_la_SOURCES)
-
-EXTRA_DIST = fbcmap.c fbcmap_mi.c
+noinst_LTLIBRARIES = libfb.la libwfb.la
+
+INCLUDES = \
+ -I$(top_srcdir)/hw/xfree86/os-support \
+ -I$(top_srcdir)/hw/xfree86/os-support/bus \
+ -I$(top_srcdir)/hw/xfree86/common
+AM_CFLAGS = $(DIX_CFLAGS)
+
+if XORG
+sdk_HEADERS = fb.h fbrop.h fboverlay.h wfbrename.h fbpict.h
+endif
+
+libfb_la_CFLAGS = $(AM_CFLAGS)
+libfb_la_LIBADD = $(PIXMAN_LIBS)
+
+libwfb_la_CFLAGS = $(AM_CFLAGS) -DFB_ACCESS_WRAPPER
+libwfb_la_LIBADD = $(PIXMAN_LIBS)
+
+libfb_la_SOURCES = \
+ fb.h \
+ fb24_32.c \
+ fb24_32.h \
+ fballpriv.c \
+ fbarc.c \
+ fbbits.c \
+ fbbits.h \
+ fbblt.c \
+ fbbltone.c \
+ fbcopy.c \
+ fbfill.c \
+ fbfillrect.c \
+ fbfillsp.c \
+ fbgc.c \
+ fbgetsp.c \
+ fbglyph.c \
+ fbimage.c \
+ fbline.c \
+ fboverlay.c \
+ fboverlay.h \
+ fbpict.c \
+ fbpict.h \
+ fbpixmap.c \
+ fbpoint.c \
+ fbpush.c \
+ fbrop.h \
+ fbscreen.c \
+ fbseg.c \
+ fbsetsp.c \
+ fbsolid.c \
+ fbstipple.c \
+ fbtile.c \
+ fbtrap.c \
+ fbutil.c \
+ fbwindow.c
+
+libwfb_la_SOURCES = $(libfb_la_SOURCES)
+
+EXTRA_DIST = fbcmap.c fbcmap_mi.c