aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/fonts.src/encodings/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2009-10-11 18:59:59 +0000
committermarha <marha@users.sourceforge.net>2009-10-11 18:59:59 +0000
commite4bc1b2bff00254f5782928d5b7b15b4db2e774c (patch)
tree9bcc1cad2fa55b8ae22d94cfbaf2a2487041fcd8 /xorg-server/fonts.src/encodings/configure.ac
parent026bf5d0c0bbcc109bfe2b2c58fc930a2e42753e (diff)
downloadvcxsrv-e4bc1b2bff00254f5782928d5b7b15b4db2e774c.tar.gz
vcxsrv-e4bc1b2bff00254f5782928d5b7b15b4db2e774c.tar.bz2
vcxsrv-e4bc1b2bff00254f5782928d5b7b15b4db2e774c.zip
Updated following packages:
encodings-1.0.3 font-adobe-75dpi-1.0.1 font-adobe-100dpi-1.0.1 font-adobe-utopia-75dpi-1.0.2 font-adobe-utopia-100dpi-1.0.2 font-adobe-utopia-type1-1.0.2 font-alias-1.0.2 font-arabic-misc-1.0.1 font-bh-75dpi-1.0.1 font-bh-100dpi-1.0.1 font-bh-lucidatypewriter-75dpi-1.0.1 font-bh-lucidatypewriter-100dpi-1.0.1 font-bh-ttf-1.0.1 font-bh-type1-1.0.1 font-bitstream-75dpi-1.0.1 font-bitstream-100dpi-1.0.1 font-bitstream-speedo-1.0.1 font-bitstream-type1-1.0.1 font-cronyx-cyrillic-1.0.1 font-cursor-misc-1.0.1 font-daewoo-misc-1.0.1 font-dec-misc-1.0.1 font-ibm-type1-1.0.1 font-isas-misc-1.0.1 font-jis-misc-1.0.1 font-micro-misc-1.0.1 font-misc-cyrillic-1.0.1 font-misc-ethiopic-1.0.1 font-misc-meltho-1.0.1 font-misc-misc-1.1.0 font-mutt-misc-1.0.1 font-schumacher-misc-1.1.0 font-screen-cyrillic-1.0.2 font-sony-misc-1.0.1 font-sun-misc-1.0.1 font-util-1.1.0 font-winitzki-cyrillic-1.0.1 font-xfree86-type1-1.0.2 libXfont-1.4.1 mkfontscale-1.0.7
Diffstat (limited to 'xorg-server/fonts.src/encodings/configure.ac')
-rw-r--r--xorg-server/fonts.src/encodings/configure.ac38
1 files changed, 21 insertions, 17 deletions
diff --git a/xorg-server/fonts.src/encodings/configure.ac b/xorg-server/fonts.src/encodings/configure.ac
index 1ecebd089..43bfa1556 100644
--- a/xorg-server/fonts.src/encodings/configure.ac
+++ b/xorg-server/fonts.src/encodings/configure.ac
@@ -1,29 +1,40 @@
AC_PREREQ([2.57])
-AC_INIT([encodings], [1.0.2], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg])
+AC_INIT([encodings], [1.0.3], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg])
AM_INIT_AUTOMAKE([foreign dist-bzip2])
-m4_ifdef([AS_HELP_STRING], , [m4_define([AS_HELP_STRING], m4_defn([AC_HELP_STRING]))])
+# Require xorg-macros: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
+XORG_DEFAULT_OPTIONS
-# mkfontscale
+AC_PROG_INSTALL
-AC_PATH_PROG(MKFONTSCALE, mkfontscale)
-if [[ -z $MKFONTSCALE ]]; then
- AC_MSG_ERROR([mkfontscale is needed to build fontenc. Please install the app/mkfontscale package from X.Org.])
-fi
+# Require X.Org's font util macros 1.1 or later
+m4_ifndef([XORG_FONT_MACROS_VERSION],
+ [m4_fatal([must install X.Org font-util 1.1 or later before running autoconf/autogen])])
+XORG_FONT_MACROS_VERSION(1.1)
+
+# mkfontscale
+XORG_FONT_REQUIRED_PROG(MKFONTSCALE, mkfontscale)
# Choose whether or not to compress encodings - default is to compress all
+AC_MSG_CHECKING([if small encodings should be compressed])
AC_ARG_ENABLE(gzip-small-encodings,
- AS_HELP_STRING([--disable-gzip-small-encodings],
+ AC_HELP_STRING([--disable-gzip-small-encodings],
[Disable compression of small encoding files]),
[GZIP_SMALL="$enableval"], [GZIP_SMALL="yes"])
AM_CONDITIONAL(GZIP_SMALL, [test x$GZIP_SMALL = xyes])
+AC_MSG_RESULT([${GZIP_SMALL}])
+AC_MSG_CHECKING([if large encodings should be compressed])
AC_ARG_ENABLE(gzip-large-encodings,
- AS_HELP_STRING([--disable-gzip-large-encodings],
+ AC_HELP_STRING([--disable-gzip-large-encodings],
[Disable compression of large encoding files]),
[GZIP_LARGE="$enableval"], [GZIP_LARGE="yes"])
AM_CONDITIONAL(GZIP_LARGE, [test x$GZIP_LARGE = xyes])
+AC_MSG_RESULT([${GZIP_LARGE}])
# gzip
@@ -34,13 +45,6 @@ if test x$GZIP_SMALL = xyes -o x$GZIP_LARGE = xyes ; then
fi
fi
-DEFAULT_ENCODINGSDIR=${libdir}/X11/fonts/encodings
-AC_ARG_WITH(encodingsdir,
- AS_HELP_STRING([--with-encodingsdir=ENCODINGSDIR], [Path to install font encodings]),
- [ENCODINGSDIR="$withval"],
- [ENCODINGSDIR="$DEFAULT_ENCODINGSDIR"])
-AC_SUBST(ENCODINGSDIR)
-
-XORG_RELEASE_VERSION
+XORG_FONTSUBDIR([ENCODINGSDIR], [encodingsdir], [encodings])
AC_OUTPUT([Makefile large/Makefile])