aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/glx/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2013-10-31 08:40:01 +0100
committermarha <marha@users.sourceforge.net>2013-10-31 08:40:01 +0100
commite4ef724e06621be9325fc41ed886fd404467fdc0 (patch)
treebe445314647f682fbb4a1e8b94aeb6ee79cede5f /xorg-server/glx/Makefile.am
parent270d3a1aa4137dc15d7b7e5a0958cc8c0bef9a1a (diff)
downloadvcxsrv-e4ef724e06621be9325fc41ed886fd404467fdc0.tar.gz
vcxsrv-e4ef724e06621be9325fc41ed886fd404467fdc0.tar.bz2
vcxsrv-e4ef724e06621be9325fc41ed886fd404467fdc0.zip
fontconfig glproto libX11 mesa xserver xkeyboard-config git update 31 oct 2013
xserver commit 902ff0b3497d202b86bf9a411e17db7b694d6eaa xkeyboard-config commit 70bbf18d6cddb7271db1b2e042765ace3c4ac485 libX11 commit 6cb02b166361200da35ba14f52cd9aaa493eb0ea glproto commit aacc7a51b6161c765b04524e0d2ab31e5e586834 fontconfig commit 525a135ccf53e4bf3363c3143d9cfdf15fba55ab mesa commit b16b3c8703f198ca0f025b730d582600df79c19c
Diffstat (limited to 'xorg-server/glx/Makefile.am')
-rw-r--r--xorg-server/glx/Makefile.am18
1 files changed, 3 insertions, 15 deletions
diff --git a/xorg-server/glx/Makefile.am b/xorg-server/glx/Makefile.am
index d1c203dc9..5f28e87da 100644
--- a/xorg-server/glx/Makefile.am
+++ b/xorg-server/glx/Makefile.am
@@ -26,7 +26,7 @@ if DRI2_AIGLX
AM_CPPFLAGS += -I$(top_srcdir)/hw/xfree86/dri2
endif
-glapi_sources = \
+indirect_sources = \
indirect_dispatch.c \
indirect_dispatch.h \
indirect_dispatch_swap.c \
@@ -35,22 +35,10 @@ glapi_sources = \
indirect_size.h \
indirect_size_get.c \
indirect_size_get.h \
- indirect_table.c \
- dispatch.h \
- glapitable.h \
- glapi.c \
- glapi.h \
- glapi_gentable.c \
- glprocs.h \
- glthread.c \
- glthread.h
+ indirect_table.c
libglxdri_la_SOURCES =
-if DRI
-libglxdri_la_SOURCES += glxdri.c
-endif
-
if DRI2_AIGLX
libglxdri_la_SOURCES += glxdri2.c
endif
@@ -59,7 +47,6 @@ libglxdri_la_LIBADD = $(DLOPEN_LIBS)
libglx_la_SOURCES = \
$(indirect_sources) \
- $(glapi_sources) \
clientinfo.c \
createcontext.c \
extension_string.c \
@@ -82,6 +69,7 @@ libglx_la_SOURCES = \
glxscreens.c \
glxscreens.h \
glxserver.h \
+ glxstubs.c \
glxutil.h \
render2.c \
render2swap.c \