aboutsummaryrefslogtreecommitdiff
path: root/apps/xwininfo/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'apps/xwininfo/configure.ac')
-rw-r--r--apps/xwininfo/configure.ac47
1 files changed, 38 insertions, 9 deletions
diff --git a/apps/xwininfo/configure.ac b/apps/xwininfo/configure.ac
index b4b8785ff..f571db31a 100644
--- a/apps/xwininfo/configure.ac
+++ b/apps/xwininfo/configure.ac
@@ -21,18 +21,21 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
-AC_PREREQ([2.57])
-AC_INIT(xwininfo, [1.0.5], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],xwininfo)
-AM_INIT_AUTOMAKE([dist-bzip2])
+AC_PREREQ([2.60])
+AC_INIT([xwininfo], [1.1.0],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xwininfo])
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
-# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
- [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.3)
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
AM_CONFIG_HEADER(config.h)
+AC_USE_SYSTEM_EXTENSIONS
+
AC_PROG_CC
AC_PROG_INSTALL
@@ -40,9 +43,35 @@ XORG_DEFAULT_OPTIONS
AC_CHECK_FUNCS([strlcat])
+AC_FUNC_STRNLEN
+if test "x$ac_cv_func_strnlen_working" = xyes; then
+ AC_DEFINE(HAVE_STRNLEN, 1, [Define to 1 if you have a working strnlen function.])
+fi
+
+# Check for iconv in libc, then libiconv
+AC_SEARCH_LIBS([iconv], [iconv], [AC_DEFINE([HAVE_ICONV], 1,
+ [Define to 1 if you have the iconv() function])])
+
+# Allow using xcb-icccm, but don't make it the default while the API is
+# still being changed.
+AC_MSG_CHECKING([whether to use xcb-icccm library])
+AC_ARG_WITH([xcb-icccm],
+ [AS_HELP_STRING([--with-xcb-icccm],
+ [use xcb-icccm (default: no)])],
+ [], [with_xcb_icccm=no])
+AC_MSG_RESULT([$with_xcb_icccm])
+if test "x$with_xcb_icccm" != xno ; then
+ AC_DEFINE([USE_XCB_ICCCM], 1,
+ [Define to 1 to call xcb-icccm library functions instead of local replacements])
+ xcb_icccm_pc="xcb-icccm"
+fi
+
# Checks for pkg-config packages
-PKG_CHECK_MODULES(XWININFO, xext x11)
-AC_SUBST(XWININFO_CFLAGS)
-AC_SUBST(XWININFO_LIBS)
+PKG_CHECK_MODULES(XWININFO, [xcb >= 1.6] xcb-shape ${xcb_icccm_pc})
+
+# Even when using xcb, xproto is still required for Xfuncproto.h
+# and libX11 headers for cursorfont.h
+PKG_CHECK_MODULES(XLIB, x11 [xproto >= 7.0.17])
+XWININFO_CFLAGS="${XWININFO_CFLAGS} ${XLIB_CFLAGS}"
AC_OUTPUT([Makefile])