aboutsummaryrefslogtreecommitdiff
path: root/fontconfig/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'fontconfig/configure.ac')
-rw-r--r--fontconfig/configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/fontconfig/configure.ac b/fontconfig/configure.ac
index 4996b7936..da19759e4 100644
--- a/fontconfig/configure.ac
+++ b/fontconfig/configure.ac
@@ -24,7 +24,6 @@ dnl
dnl Process this file with autoconf to create configure.
AC_PREREQ(2.61)
-AC_INIT(fonts.dtd)
dnl ==========================================================================
dnl Versioning
@@ -34,7 +33,8 @@ dnl This is the package version number, not the shared library
dnl version. This same version number must appear in fontconfig/fontconfig.h
dnl Yes, it is a pain to synchronize version numbers. Unfortunately, it's
dnl not possible to extract the version number here from fontconfig.h
-AM_INIT_AUTOMAKE(fontconfig, 2.10.91)
+AC_INIT([fontconfig], [2.10.91], [https://bugs.freedesktop.org/enger_bug.cgi?product=fontconfig])
+AM_INIT_AUTOMAKE
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
dnl libtool versioning
@@ -70,6 +70,9 @@ AC_PROG_MAKE_SET
PKG_PROG_PKG_CONFIG
m4_ifdef([PKG_INSTALLDIR], [PKG_INSTALLDIR], AC_SUBST([pkgconfigdir], ${libdir}/pkgconfig))
+AM_MISSING_PROG([GIT], [git])
+AM_MISSING_PROG([GPERF], [gperf])
+
AC_MSG_CHECKING([for RM macro])
_predefined_rm=`make -p -f /dev/null 2>/dev/null|grep '^RM ='|sed -e 's/^RM = //'`
if test "x$_predefined_rm" = "x"; then
@@ -681,7 +684,7 @@ dnl include the header file for workaround of miscalculating size on autoconf
dnl particularly for fat binaries
AH_BOTTOM([#include "config-fixups.h"])
-AC_OUTPUT([
+AC_CONFIG_FILES([
Makefile
fontconfig/Makefile
fc-lang/Makefile
@@ -704,3 +707,4 @@ fontconfig.spec
fontconfig.pc
fontconfig-zip
])
+AC_OUTPUT