aboutsummaryrefslogtreecommitdiff
path: root/fontconfig/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'fontconfig/configure.in')
-rw-r--r--fontconfig/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/fontconfig/configure.in b/fontconfig/configure.in
index da6ef9532..3204f2e5d 100644
--- a/fontconfig/configure.in
+++ b/fontconfig/configure.in
@@ -64,6 +64,15 @@ AC_LIBTOOL_WIN32_DLL
AM_PROG_LIBTOOL
AC_PROG_MAKE_SET
+AC_MSG_CHECKING([for RM macro])
+_predefined_rm=`make -p -f /dev/null 2>/dev/null|grep '^RM ='|sed -e 's/^RM = //'`
+if test "x$_predefined_rm" = "x"; then
+ AC_MSG_RESULT([no predefined RM])
+ AC_CHECK_PROG(RM, rm, [rm -f])
+else
+ AC_MSG_RESULT($_predefined_rm)
+fi
+
dnl ==========================================================================
case "$host" in