aboutsummaryrefslogtreecommitdiff
path: root/fontconfig/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'fontconfig/configure.in')
-rw-r--r--fontconfig/configure.in89
1 files changed, 57 insertions, 32 deletions
diff --git a/fontconfig/configure.in b/fontconfig/configure.in
index 62bc25e4a..b77c52a29 100644
--- a/fontconfig/configure.in
+++ b/fontconfig/configure.in
@@ -123,7 +123,7 @@ dnl ==========================================================================
# Checks for header files.
AC_HEADER_DIRENT
AC_HEADER_STDC
-AC_CHECK_HEADERS([fcntl.h regex.h stdlib.h string.h unistd.h])
+AC_CHECK_HEADERS([fcntl.h regex.h stdlib.h string.h unistd.h sys/vfs.h sys/statfs.h sys/param.h sys/mount.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -133,9 +133,29 @@ AC_TYPE_PID_T
# Checks for library functions.
AC_FUNC_VPRINTF
AC_FUNC_MMAP
-AC_CHECK_FUNCS([geteuid getuid link memmove memset mkstemp strchr strrchr strtol getopt getopt_long sysconf ftruncate chsize rand random lrand48 random_r rand_r regcomp regerror regexec regfree posix_fadvise])
+AC_CHECK_FUNCS([geteuid getuid link memmove memset mkstemp strchr strrchr strtol getopt getopt_long sysconf ftruncate chsize rand random lrand48 random_r rand_r regcomp regerror regexec regfree posix_fadvise fstatvfs fstatfs])
#
+if test "x$ac_cv_func_fstatvfs" = "xyes"; then
+ AC_CHECK_MEMBERS([struct statvfs.f_basetype, struct statvfs.f_fstypename],,,
+ [#include <sys/statvfs.h>])
+fi
+if test "x$ac_cv_func_fstatfs" = "xyes"; then
+ AC_CHECK_MEMBERS([struct statfs.f_flags, struct statfs.f_fstypename],,, [
+#ifdef HAVE_SYS_VFS_H
+#include <sys/vfs.h>
+#endif
+#ifdef HAVE_SYS_STATFS_H
+#include <sys/statfs.h>
+#endif
+#ifdef HAVE_SYS_PARAM_H
+#include <sys/param.h>
+#endif
+#ifdef HAVE_SYS_MOUNT_H
+#include <sys/mount.h>
+#endif])
+fi
+#
# regex
#
if test "x$ac_cv_func_regcomp" = "xyes" -a "x$ac_cv_func_regerror" = "xyes" -a "x$ac_cv_func_regexec" = "xyes" -a "x$ac_cv_func_regfree"; then
@@ -145,6 +165,10 @@ fi
#
# Checks for iconv
#
+AC_ARG_ENABLE(iconv,
+ [AC_HELP_STRING([--enable-iconv],
+ [Use iconv to support non-Unicode SFNT name])],
+ ,enable_iconv=no)
AC_ARG_WITH(libiconv,
[AC_HELP_STRING([--with-libiconv=DIR],
[Use libiconv in DIR])],
@@ -186,38 +210,39 @@ if test "x$libiconv_cflags" != "x"; then
fi
use_iconv=0
-AC_MSG_CHECKING([for a usable iconv])
-if test "x$libiconv_cflags" != "x" -o "x$libiconv_libs" != "x"; then
- iconvsaved_CFLAGS="$CFLAGS"
- iconvsaved_LIBS="$LIBS"
- CFLAGS="$CFLAGS $libiconv_cflags"
- LIBS="$LIBS $libiconv_libs"
-
- AC_TRY_LINK([#include <iconv.h>],
- [iconv_open ("from", "to");],
- [iconv_type="libiconv"
- use_iconv=1],
- [use_iconv=0])
-
- CFLAGS="$iconvsaved_CFLAGS"
- LIBS="$iconvsaved_LIBS"
- ICONV_CFLAGS="$libiconv_cflags"
- ICONV_LIBS="$libiconv_libs"
-fi
-if test "x$use_iconv" = "x0"; then
- AC_TRY_LINK([#include <iconv.h>],
- [iconv_open ("from", "to");],
- [iconv_type="libc"
- use_iconv=1],
- [iconv_type="not found"
- use_iconv=0])
-fi
+if test "x$enable_iconv" != "xno"; then
+ AC_MSG_CHECKING([for a usable iconv])
+ if test "x$libiconv_cflags" != "x" -o "x$libiconv_libs" != "x"; then
+ iconvsaved_CFLAGS="$CFLAGS"
+ iconvsaved_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $libiconv_cflags"
+ LIBS="$LIBS $libiconv_libs"
+
+ AC_TRY_LINK([#include <iconv.h>],
+ [iconv_open ("from", "to");],
+ [iconv_type="libiconv"
+ use_iconv=1],
+ [use_iconv=0])
+
+ CFLAGS="$iconvsaved_CFLAGS"
+ LIBS="$iconvsaved_LIBS"
+ ICONV_CFLAGS="$libiconv_cflags"
+ ICONV_LIBS="$libiconv_libs"
+ fi
+ if test "x$use_iconv" = "x0"; then
+ AC_TRY_LINK([#include <iconv.h>],
+ [iconv_open ("from", "to");],
+ [iconv_type="libc"
+ use_iconv=1],
+ [iconv_type="not found"
+ use_iconv=0])
+ fi
-AC_MSG_RESULT([$iconv_type])
-AC_SUBST(ICONV_CFLAGS)
-AC_SUBST(ICONV_LIBS)
+ AC_MSG_RESULT([$iconv_type])
+ AC_SUBST(ICONV_CFLAGS)
+ AC_SUBST(ICONV_LIBS)
+fi
AC_DEFINE_UNQUOTED(USE_ICONV,$use_iconv,[Use iconv.])
-
#
# Checks for FreeType
#