aboutsummaryrefslogtreecommitdiff
path: root/fontconfig/fc-glyphname/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fontconfig/fc-glyphname/Makefile.am')
-rw-r--r--fontconfig/fc-glyphname/Makefile.am18
1 files changed, 10 insertions, 8 deletions
diff --git a/fontconfig/fc-glyphname/Makefile.am b/fontconfig/fc-glyphname/Makefile.am
index bcb4d0746..3799880e5 100644
--- a/fontconfig/fc-glyphname/Makefile.am
+++ b/fontconfig/fc-glyphname/Makefile.am
@@ -7,9 +7,9 @@
# documentation for any purpose is hereby granted without fee, provided that
# the above copyright notice appear in all copies and that both that
# copyright notice and this permission notice appear in supporting
-# documentation, and that the name of Keith Packard not be used in
+# documentation, and that the name of the author(s) not be used in
# advertising or publicity pertaining to distribution of the software without
-# specific, written prior permission. Keith Packard makes no
+# specific, written prior permission. The authors make no
# representations about the suitability of this software for any purpose. It
# is provided "as is" without express or implied warranty.
#
@@ -22,10 +22,6 @@
# PERFORMANCE OF THIS SOFTWARE.
#
-CC = @CC_FOR_BUILD@
-EXEEXT = @EXEEXT_FOR_BUILD@
-LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
-
INCLUDES=-I${top_srcdir}/src -I${top_srcdir} $(WARN_CFLAGS)
TMPL=fcglyphname.tmpl.h
@@ -37,12 +33,17 @@ noinst_PROGRAMS=fc-glyphname
GLYPHNAME=zapfdingbats.txt
SGLYPHNAME=${top_srcdir}/fc-glyphname/zapfdingbats.txt
-EXTRA_DIST=$(TMPL) $(GLYPHNAME)
+EXTRA_DIST = $(TARG) $(TMPL) $(GLYPHNAME)
+if CROSS_COMPILING
+$(TARG): $(STMPL) fc-glyphname.c $(SGLYPHNAME)
+ @echo Warning: cannot rebuild $(TARG) when cross-compiling
+else
$(TARG): $(STMPL) fc-glyphname$(EXEEXT) $(SGLYPHNAME)
$(AM_V_GEN) $(RM) $(TARG); \
./fc-glyphname$(EXEEXT) $(SGLYPHNAME) < $(STMPL) > $(TARG).tmp && \
mv $(TARG).tmp $(TARG)
+endif
ALIAS_FILES = fcalias.h fcaliastail.h
@@ -51,5 +52,6 @@ BUILT_SOURCES = $(ALIAS_FILES) $(TARG)
$(ALIAS_FILES):
touch $(ALIAS_FILES)
-CLEANFILES=$(TARG) $(ALIAS_FILES)
+CLEANFILES = $(ALIAS_FILES)
+MAINTAINERCLEANFILES = $(TARG)