aboutsummaryrefslogtreecommitdiff
path: root/libX11/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libX11/Makefile.am')
-rw-r--r--libX11/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/libX11/Makefile.am b/libX11/Makefile.am
new file mode 100644
index 000000000..944aaa0cb
--- /dev/null
+++ b/libX11/Makefile.am
@@ -0,0 +1,34 @@
+if XLIB_LOADABLE_I18N
+ORDER=src modules
+else
+ORDER=modules src
+endif
+SUBDIRS=include $(ORDER) nls man
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = x11.pc
+if XCB
+pkgconfig_DATA += x11-xcb.pc
+endif
+
+EXTRA_DIST=x11.pc.in x11-xcb.pc.in ChangeLog autogen.sh
+
+MAINTAINERCLEANFILES=ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
+
+if LINT
+# Check source code with tools like lint & sparse
+LINT_SUBDIRS=src # modules
+
+lint:
+ @for subdir in $(LINT_SUBDIRS) ; do \
+ echo "Making $@ in $$subdir"; \
+ (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) lint) ; \
+ done
+endif LINT