aboutsummaryrefslogtreecommitdiff
path: root/libX11/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'libX11/configure.ac')
-rw-r--r--libX11/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/libX11/configure.ac b/libX11/configure.ac
index 8bd2e51e0..60a7790d8 100644
--- a/libX11/configure.ac
+++ b/libX11/configure.ac
@@ -279,7 +279,7 @@ AM_CONDITIONAL(THRSTUBS, test x$thrstubs = xyes)
# XXX incomplete, please fill this in
if test x$xthreads = xyes ; then
case $host_os in
- linux*|openbsd*|gnu*|k*bsd*-gnu)
+ linux*|gnu*|k*bsd*-gnu)
XTHREADLIB=-lpthread ;;
netbsd*)
XTHREAD_CFLAGS="-D_POSIX_THREAD_SAFE_FUNCTIONS"
@@ -287,7 +287,7 @@ if test x$xthreads = xyes ; then
freebsd*)
XTHREAD_CFLAGS="-D_THREAD_SAFE"
XTHREADLIB="-pthread" ;;
- dragonfly*)
+ dragonfly*|openbsd*)
XTHREADLIB="-pthread" ;;
solaris*)
XTHREAD_CFLAGS="-D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS" ;;