aboutsummaryrefslogtreecommitdiff
path: root/libX11/modules/lc/gen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libX11/modules/lc/gen/Makefile.am')
-rw-r--r--libX11/modules/lc/gen/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/libX11/modules/lc/gen/Makefile.am b/libX11/modules/lc/gen/Makefile.am
new file mode 100644
index 000000000..2937cb19d
--- /dev/null
+++ b/libX11/modules/lc/gen/Makefile.am
@@ -0,0 +1,30 @@
+AM_CFLAGS= \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/include/X11 \
+ -I$(top_builddir)/include \
+ -I$(top_builddir)/include/X11 \
+ -I$(top_srcdir)/src/xcms \
+ -I$(top_srcdir)/src/xkb \
+ -I$(top_srcdir)/src/xlibi18n \
+ $(X11_CFLAGS) \
+ $(BIGFONT_CFLAGS) \
+ $(XDMCP_CFLAGS) \
+ -D_BSD_SOURCE
+
+if XLIB_LOADABLE_I18N
+
+commonlibdir = $(X11_LOCALELIBDIR)/common
+commonlib_LTLIBRARIES=xlibi18n.la
+xlibi18n_la_LDFLAGS = -module -version-number 2:0:0
+xlibi18n_la_LIBADD = $(I18N_MODULE_LIBS)
+
+else
+
+noinst_LTLIBRARIES = libxlibi18n.la
+
+endif
+
+xlibi18n_la_SOURCES = \
+ lcGenConv.c
+
+libxlibi18n_la_SOURCES = $(xlibi18n_la_SOURCES)