aboutsummaryrefslogtreecommitdiff
path: root/libX11/modules/lc/xlocale/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libX11/modules/lc/xlocale/Makefile.am')
-rw-r--r--libX11/modules/lc/xlocale/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/libX11/modules/lc/xlocale/Makefile.am b/libX11/modules/lc/xlocale/Makefile.am
new file mode 100644
index 000000000..be8dd41c1
--- /dev/null
+++ b/libX11/modules/lc/xlocale/Makefile.am
@@ -0,0 +1,33 @@
+AM_CFLAGS= \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/include/X11 \
+ -I$(top_builddir)/include \
+ -I$(top_builddir)/include/X11 \
+ -I$(top_srcdir)/src/xcms \
+ -I$(top_srcdir)/src/xkb \
+ -I$(top_srcdir)/src/xlibi18n \
+ $(X11_CFLAGS) \
+ $(BIGFONT_CFLAGS) \
+ $(XDMCP_CFLAGS) \
+ -D_BSD_SOURCE
+
+if XLIB_LOADABLE_I18N
+
+commonlibdir = $(X11_LOCALELIBDIR)/common
+commonlib_LTLIBRARIES=xlocale.la
+xlocale_la_LDFLAGS = -module -version-number 2:0:0
+xlocale_la_LIBADD = $(I18N_MODULE_LIBS)
+
+else
+
+noinst_LTLIBRARIES = libxlocale.la
+
+endif
+
+
+xlocale_la_SOURCES = \
+ lcEuc.c \
+ lcJis.c \
+ lcSjis.c
+
+libxlocale_la_SOURCES = $(xlocale_la_SOURCES)