aboutsummaryrefslogtreecommitdiff
path: root/libXfixes/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'libXfixes/configure.ac')
-rw-r--r--libXfixes/configure.ac65
1 files changed, 65 insertions, 0 deletions
diff --git a/libXfixes/configure.ac b/libXfixes/configure.ac
new file mode 100644
index 000000000..fc8c1e1a4
--- /dev/null
+++ b/libXfixes/configure.ac
@@ -0,0 +1,65 @@
+#
+# Copyright © 2003 Keith Packard, Noah Levitt
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Keith Packard not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Keith Packard makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+#
+
+# Initialize Autoconf
+AC_PREREQ([2.60])
+
+#
+# Version should match the current XFixes version. XFixesQueryVersion
+# returns the version from xfixeswire.h, NOT the version we set here. But we
+# try to keep these the same. Note that the library has an extra
+# digit in the version number to track changes which don't affect the
+# protocol, so Xfixes version l.n.m corresponds to protocol version l.n,
+# that 'revision' number appears in Xfixes.h and has to be manually
+# synchronized.
+#
+AC_INIT(libXfixes, [5.0],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [libXfixes])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AM_MAINTAINER_MODE
+
+# Initialize libtool
+AC_PROG_LIBTOOL
+
+# Require xorg-macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
+XORG_DEFAULT_OPTIONS
+
+# Check fixesext configuration, strip extra digits from package version to
+# find the required protocol version
+FIXESEXT_VERSION=[`echo $VERSION | sed 's/^\([0-9][0-9]*\.[0-9][0-9]*\).*$/\1/'`]
+AC_SUBST(FIXESEXT_VERSION)
+
+# Obtain compiler/linker options for depedencies
+PKG_CHECK_MODULES(FIXESEXT, xproto [fixesproto >= $FIXESEXT_VERSION] xextproto x11)
+
+AC_CONFIG_FILES([Makefile
+ src/Makefile
+ man/Makefile
+ xfixes.pc])
+AC_OUTPUT