aboutsummaryrefslogtreecommitdiff
path: root/libxcb/xcb-proto/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'libxcb/xcb-proto/configure.ac')
-rw-r--r--libxcb/xcb-proto/configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/libxcb/xcb-proto/configure.ac b/libxcb/xcb-proto/configure.ac
new file mode 100644
index 000000000..f3a489e2b
--- /dev/null
+++ b/libxcb/xcb-proto/configure.ac
@@ -0,0 +1,22 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.57)
+AC_INIT([XCB Proto],
+ 1.5,
+ [xcb@lists.freedesktop.org])
+AC_CONFIG_SRCDIR([xcb-proto.pc.in])
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+
+AC_PATH_PROG(XMLLINT, xmllint, no)
+AM_CONDITIONAL(HAVE_XMLLINT, test "x$XMLLINT" != "xno")
+if test "$XMLLINT" = "no"; then
+ AC_MSG_WARN([xmllint not found; unable to validate against schema.])
+fi
+
+AM_PATH_PYTHON([2.5])
+
+xcbincludedir='${datadir}/xcb'
+AC_SUBST(xcbincludedir)
+
+AC_OUTPUT([Makefile src/Makefile xcbgen/Makefile xcb-proto.pc])