aboutsummaryrefslogtreecommitdiff
path: root/mesalib/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mesalib/src/Makefile.am')
-rw-r--r--mesalib/src/Makefile.am21
1 files changed, 18 insertions, 3 deletions
diff --git a/mesalib/src/Makefile.am b/mesalib/src/Makefile.am
index 3e736d029..8edf33373 100644
--- a/mesalib/src/Makefile.am
+++ b/mesalib/src/Makefile.am
@@ -19,7 +19,9 @@
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
# IN THE SOFTWARE.
-SUBDIRS = gtest util mapi
+AUTOMAKE_OPTIONS = subdir-objects
+
+SUBDIRS = . gtest util mapi/glapi/gen mapi
if NEED_OPENGL_COMMON
SUBDIRS += glsl mesa
@@ -32,7 +34,7 @@ SUBDIRS += glx
endif
if HAVE_EGL_PLATFORM_WAYLAND
-SUBDIRS += egl/wayland
+SUBDIRS += egl/wayland/wayland-egl egl/wayland/wayland-drm
endif
if HAVE_EGL_DRIVER_DRI2
@@ -51,4 +53,17 @@ if HAVE_GALLIUM
SUBDIRS += gallium
endif
-EXTRA_DIST = getopt
+EXTRA_DIST = egl/docs getopt hgl SConscript
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include/ \
+ -I$(top_srcdir)/src/mapi/ \
+ -I$(top_srcdir)/src/mesa/ \
+ $(DEFINES)
+
+noinst_LTLIBRARIES = libglsl_util.la
+
+libglsl_util_la_SOURCES = \
+ mesa/main/imports.c \
+ mesa/program/prog_hash_table.c \
+ mesa/program/symbol_table.c