aboutsummaryrefslogtreecommitdiff
path: root/mesalib/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mesalib/src/Makefile.am')
-rw-r--r--mesalib/src/Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/mesalib/src/Makefile.am b/mesalib/src/Makefile.am
index 85b75a93b..8edf33373 100644
--- a/mesalib/src/Makefile.am
+++ b/mesalib/src/Makefile.am
@@ -19,7 +19,9 @@
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
# IN THE SOFTWARE.
-SUBDIRS = gtest util mapi/glapi/gen mapi
+AUTOMAKE_OPTIONS = subdir-objects
+
+SUBDIRS = . gtest util mapi/glapi/gen mapi
if NEED_OPENGL_COMMON
SUBDIRS += glsl mesa
@@ -52,3 +54,16 @@ SUBDIRS += gallium
endif
EXTRA_DIST = egl/docs getopt hgl SConscript
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include/ \
+ -I$(top_srcdir)/src/mapi/ \
+ -I$(top_srcdir)/src/mesa/ \
+ $(DEFINES)
+
+noinst_LTLIBRARIES = libglsl_util.la
+
+libglsl_util_la_SOURCES = \
+ mesa/main/imports.c \
+ mesa/program/prog_hash_table.c \
+ mesa/program/symbol_table.c