aboutsummaryrefslogtreecommitdiff
path: root/mesalib/src/glsl/builtin_compiler/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mesalib/src/glsl/builtin_compiler/Makefile.am')
-rw-r--r--mesalib/src/glsl/builtin_compiler/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/mesalib/src/glsl/builtin_compiler/Makefile.am b/mesalib/src/glsl/builtin_compiler/Makefile.am
index 72032b524..d6f85a7f4 100644
--- a/mesalib/src/glsl/builtin_compiler/Makefile.am
+++ b/mesalib/src/glsl/builtin_compiler/Makefile.am
@@ -35,6 +35,7 @@ AM_CFLAGS = \
-I $(top_srcdir)/src/mesa \
-I $(GLSL_SRCDIR) \
-I $(GLSL_SRCDIR)/glcpp \
+ -I $(GLSL_BUILDDIR) \
$(DEFINES_FOR_BUILD)
AM_CXXFLAGS = $(AM_CFLAGS)
@@ -51,7 +52,7 @@ builtin_compiler_SOURCES = \
$(GLSL_SRCDIR)/glcpp/glcpp-parse.y \
$(LIBGLCPP_FILES) \
$(GLSL_SRCDIR)/glsl_lexer.ll \
- $(GLSL_SRCDIR)/glsl_parser.cc \
+ $(GLSL_BUILDDIR)/glsl_parser.cc \
$(LIBGLSL_FILES) \
$(LIBGLSL_CXX_FILES) \
$(top_srcdir)/src/mesa/program/hash_table.c \