aboutsummaryrefslogtreecommitdiff
path: root/mesalib/src/mapi/glapi/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mesalib/src/mapi/glapi/Makefile.am')
-rw-r--r--mesalib/src/mapi/glapi/Makefile.am64
1 files changed, 0 insertions, 64 deletions
diff --git a/mesalib/src/mapi/glapi/Makefile.am b/mesalib/src/mapi/glapi/Makefile.am
deleted file mode 100644
index cadcd69d6..000000000
--- a/mesalib/src/mapi/glapi/Makefile.am
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright © 2012 Jon TURNEY
-#
-# Permission is hereby granted, free of charge, to any person obtaining a
-# copy of this software and associated documentation files (the "Software"),
-# to deal in the Software without restriction, including without limitation
-# the rights to use, copy, modify, merge, publish, distribute, sublicense,
-# and/or sell copies of the Software, and to permit persons to whom the
-# Software is furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice (including the next
-# paragraph) shall be included in all copies or substantial portions of the
-# Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
-# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
-# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
-# IN THE SOFTWARE.
-
-SUBDIRS = . tests
-
-TOP = $(top_srcdir)
-include Makefile.sources
-include ../Makefile.sources
-
-AM_CPPFLAGS = \
- $(DEFINES) \
- $(SELINUX_CFLAGS) \
- -I$(top_srcdir)/include \
- -I$(top_srcdir)/src/mapi \
- -I$(top_builddir)/src/mapi \
- -I$(top_srcdir)/src/mesa
-
-if HAVE_X86_ASM
-if HAVE_X86_64_ASM
-GLAPI_ASM_SOURCES = $(X86_64_API)
-else
-GLAPI_ASM_SOURCES = $(X86_API)
-endif
-endif
-if HAVE_SPARC_ASM
-GLAPI_ASM_SOURCES = $(SPARC_API)
-endif
-
-if HAVE_SHARED_GLAPI
-AM_CPPFLAGS += \
- -DMAPI_MODE_BRIDGE \
- -DMAPI_ABI_HEADER=\"glapi/glapi_mapi_tmp.h\"
-glapi_GLAPI_sources = $(GLAPI_UTIL_SOURCES)
-glapi_ASM_sources =
-glapi_MAPI_sources = $(MAPI_BRIDGE_FILES)
-else
-AM_CPPFLAGS += \
- -DMAPI_MODE_UTIL
-glapi_GLAPI_sources = $(GLAPI_SOURCES) $(GLAPI_UTIL_SOURCES)
-glapi_ASM_sources = $(GLAPI_ASM_SOURCES)
-glapi_MAPI_sources = $(MAPI_UTIL_FILES)
-endif
-
-noinst_LTLIBRARIES = libglapi.la
-
-libglapi_la_SOURCES = $(glapi_GLAPI_sources) $(glapi_ASM_sources) $(glapi_MAPI_sources)