aboutsummaryrefslogtreecommitdiff
path: root/mesalib/src/mapi/glapi/gen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mesalib/src/mapi/glapi/gen/Makefile.am')
-rw-r--r--mesalib/src/mapi/glapi/gen/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/mesalib/src/mapi/glapi/gen/Makefile.am b/mesalib/src/mapi/glapi/gen/Makefile.am
index 499ec09a8..40aaf51cd 100644
--- a/mesalib/src/mapi/glapi/gen/Makefile.am
+++ b/mesalib/src/mapi/glapi/gen/Makefile.am
@@ -38,10 +38,18 @@ MESA_GLAPI_OUTPUTS = \
$(MESA_GLAPI_DIR)/glapitable.h \
$(MESA_GLAPI_DIR)/glapi_gentable.c
-MESA_GLAPI_ASM_OUTPUTS = \
- $(MESA_GLAPI_DIR)/glapi_x86.S \
- $(MESA_GLAPI_DIR)/glapi_x86-64.S \
- $(MESA_GLAPI_DIR)/glapi_sparc.S
+MESA_GLAPI_ASM_OUTPUTS =
+if HAVE_X86_ASM
+MESA_GLAPI_ASM_OUTPUTS += $(MESA_GLAPI_DIR)/glapi_x86.S
+endif
+
+if HAVE_X86_64_ASM
+MESA_GLAPI_ASM_OUTPUTS += $(MESA_GLAPI_DIR)/glapi_x86-64.S
+endif
+
+if HAVE_SPARC_ASM
+MESA_GLAPI_ASM_OUTPUTS += $(MESA_GLAPI_DIR)/glapi_sparc.S
+endif
MESA_OUTPUTS = \
$(MESA_GLAPI_OUTPUTS) \