aboutsummaryrefslogtreecommitdiff
path: root/mkfontscale/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'mkfontscale/configure.ac')
-rw-r--r--mkfontscale/configure.ac16
1 files changed, 7 insertions, 9 deletions
diff --git a/mkfontscale/configure.ac b/mkfontscale/configure.ac
index 7129d8764..490e8cc45 100644
--- a/mkfontscale/configure.ac
+++ b/mkfontscale/configure.ac
@@ -21,20 +21,22 @@ dnl
dnl Process this file with autoconf to create configure.
AC_PREREQ([2.57])
-AC_INIT(mkfontscale, [1.0.6], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], mkfontscale)
+AC_INIT(mkfontscale, [1.0.7], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], mkfontscale)
AM_INIT_AUTOMAKE([dist-bzip2 foreign])
AM_MAINTAINER_MODE
AM_CONFIG_HEADER(config.h)
-# Require xorg-macros version >= 1.2.0 for XORG_CWARNFLAGS & XORG_CHANGELOG
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.2)
+# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
AC_PROG_CC
-XORG_CWARNFLAGS
AC_PROG_INSTALL
+XORG_DEFAULT_OPTIONS
+
AC_CHECK_LIB(z, gzopen, [],
[AC_MSG_ERROR([zlib is required, but was not found.])])
@@ -59,8 +61,4 @@ AC_SUBST(X11_CFLAGS)
dnl Allow checking code with lint, sparse, etc.
XORG_WITH_LINT
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
-XORG_CHANGELOG
-
AC_OUTPUT([Makefile])