aboutsummaryrefslogtreecommitdiff
path: root/mkfontscale/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'mkfontscale/configure.ac')
-rw-r--r--mkfontscale/configure.ac34
1 files changed, 17 insertions, 17 deletions
diff --git a/mkfontscale/configure.ac b/mkfontscale/configure.ac
index 490e8cc45..b7f72aa5d 100644
--- a/mkfontscale/configure.ac
+++ b/mkfontscale/configure.ac
@@ -20,21 +20,22 @@ dnl USE OR PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
-AC_PREREQ([2.57])
-AC_INIT(mkfontscale, [1.0.7], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], mkfontscale)
-AM_INIT_AUTOMAKE([dist-bzip2 foreign])
-AM_MAINTAINER_MODE
+# Initialize Autoconf
+AC_PREREQ([2.60])
+AC_INIT([mkfontscale], [1.0.8],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
+ [mkfontscale])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
-AM_CONFIG_HEADER(config.h)
+# Initialize Automake
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AM_MAINTAINER_MODE
-# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
- [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.3)
-
-AC_PROG_CC
-AC_PROG_INSTALL
-
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
AC_CHECK_LIB(z, gzopen, [],
@@ -52,13 +53,12 @@ fi
# Checks for pkg-config packages
PKG_CHECK_MODULES(MKFONTSCALE, fontenc freetype2)
-AC_SUBST(MKFONTSCALE_CFLAGS)
-AC_SUBST(MKFONTSCALE_LIBS)
-
PKG_CHECK_MODULES(X11, xproto)
-AC_SUBST(X11_CFLAGS)
dnl Allow checking code with lint, sparse, etc.
XORG_WITH_LINT
-AC_OUTPUT([Makefile])
+AC_CONFIG_FILES([
+ Makefile
+ man/Makefile])
+AC_OUTPUT