aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/Xext/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/Xext/Makefile.am')
-rw-r--r--xorg-server/Xext/Makefile.am62
1 files changed, 9 insertions, 53 deletions
diff --git a/xorg-server/Xext/Makefile.am b/xorg-server/Xext/Makefile.am
index 648736d95..2f5c98b90 100644
--- a/xorg-server/Xext/Makefile.am
+++ b/xorg-server/Xext/Makefile.am
@@ -15,23 +15,22 @@ INCLUDES = -I$(top_srcdir)/hw/xfree86/dixmods/extmod
AM_CFLAGS = $(DIX_CFLAGS)
if XORG
-sdk_HEADERS = xvdix.h xvmcext.h
+sdk_HEADERS = xvdix.h xvmcext.h geext.h geint.h shmint.h
endif
# Sources always included in libXextbuiltin.la & libXext.la
BUILTIN_SRCS = \
+ bigreq.c \
+ geext.c \
shape.c \
sleepuntil.c \
sleepuntil.h \
+ sync.c \
+ xcmisc.c \
xtest.c
-# Sources always included in libXextmodule.la & libXext.la
-MODULE_SRCS = \
- bigreq.c \
- mitmisc.c \
- shape.c \
- sync.c \
- xcmisc.c
+# Sources always included in libXextmodule.la & libXext.la. That's right, zero.
+MODULE_SRCS =
# Optional sources included if extension enabled by configure.ac rules
@@ -91,39 +90,6 @@ BUILTIN_SRCS += $(XCALIBRATE_SRCS)
# XCalibrate needs tslib
endif
-# X EVent Interception Extension: allows accessibility helpers & composite
-# managers to intercept events from input devices and transform as needed
-# before the clients see them.
-XEVIE_SRCS = xevie.c
-if XEVIE
-BUILTIN_SRCS += $(XEVIE_SRCS)
-endif
-
-# XPrint: Printing via X Protocol
-XPRINT_SRCS = xprint.c
-if XPRINT
-BUILTIN_SRCS += $(XPRINT_SRCS)
-endif
-
-# AppGroup
-APPGROUP_SRCS = appgroup.c appgroup.h
-if APPGROUP
-BUILTIN_SRCS += $(APPGROUP_SRCS)
-endif
-
-# Colormap Utilization Protocol: Less flashing when switching between
-# PsuedoColor apps and better sharing of limited colormap slots
-CUP_SRCS = cup.c
-if CUP
-MODULE_SRCS += $(CUP_SRCS)
-endif
-
-# Extended Visual Information
-EVI_SRCS = EVI.c sampleEVI.c EVIstruct.h
-if EVI
-MODULE_SRCS += $(EVI_SRCS)
-endif
-
# Multi-buffering extension
MULTIBUFFER_SRCS = mbuf.c
EXTRA_MULTIBUFFER_SRCS = mbufbf.c mbufpx.c
@@ -131,12 +97,6 @@ if MULTIBUFFER
MODULE_SRCS += $(MULTIBUFFER_SRCS)
endif
-# Font Cache extension
-FONTCACHE_SRCS = fontcache.c
-if FONTCACHE
-MODULE_SRCS += $(FONTCACHE_SRCS)
-endif
-
# XF86 Big Font extension
BIGFONT_SRCS = xf86bigfont.c
if XF86BIGFONT
@@ -168,14 +128,10 @@ EXTRA_DIST = \
$(XCSECURITY_SRCS) \
$(XCALIBRATE_SRCS) \
$(XINERAMA_SRCS) \
- $(XEVIE_SRCS) \
- $(XPRINT_SRCS) \
- $(APPGROUP_SRCS) \
- $(CUP_SRCS) \
- $(EVI_SRCS) \
$(MULTIBUFFER_SRCS) \
$(EXTRA_MULTIBUFFER_SRCS) \
$(FONTCACHE_SRCS) \
$(BIGFONT_SRCS) \
- $(DPMS_SRCS)
+ $(DPMS_SRCS) \
+ $(GE_SRCS)