aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/config/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/config/Makefile.am')
-rw-r--r--xorg-server/config/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/xorg-server/config/Makefile.am b/xorg-server/config/Makefile.am
new file mode 100644
index 000000000..056f30ed0
--- /dev/null
+++ b/xorg-server/config/Makefile.am
@@ -0,0 +1,22 @@
+AM_CFLAGS = @DIX_CFLAGS@
+
+noinst_LIBRARIES = libconfig.a
+libconfig_a_SOURCES = config.c config-backends.h
+
+if HAVE_DBUS
+AM_CFLAGS += @DBUS_CFLAGS@
+libconfig_a_SOURCES += dbus-core.c
+endif
+
+if CONFIG_DBUS_API
+dbusconfigdir = $(sysconfdir)/dbus-1/system.d
+dbusconfig_DATA = xorg-server.conf
+
+libconfig_a_SOURCES += dbus.c
+endif
+
+if CONFIG_HAL
+libconfig_a_SOURCES += hal.c
+endif
+
+EXTRA_DIST = xorg-server.conf x11-input.fdi