aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/configure.ac')
-rw-r--r--xorg-server/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/xorg-server/configure.ac b/xorg-server/configure.ac
index 30c0c5cd9..c6971889c 100644
--- a/xorg-server/configure.ac
+++ b/xorg-server/configure.ac
@@ -217,10 +217,12 @@ AC_SUBST(DLOPEN_LIBS)
dnl Checks for library functions.
AC_CHECK_FUNCS([backtrace ffs geteuid getuid issetugid getresuid \
- getdtablesize getifaddrs getpeereid getpeerucred getzoneid \
+ getdtablesize getifaddrs getpeereid getpeerucred getprogname getzoneid \
mmap seteuid shmctl64 strncasecmp vasprintf vsnprintf walkcontext])
AC_REPLACE_FUNCS([strcasecmp strcasestr strlcat strlcpy strndup])
+AC_CHECK_DECLS([program_invocation_short_name], [], [], [[#include <errno.h>]])
+
dnl Find the math libary, then check for cbrt function in it.
AC_CHECK_LIB(m, sqrt)
AC_CHECK_FUNCS([cbrt])